0

I have created a custom WCF Web Service in a SharePoint solution and deployed it to a SharePoint 2013 environment. The svc file is located in the ISAPI folder and I am able to call it and use it successfully.

However, I am having issues when working with dates within the service. The CultureInfo.CurrentCulture is returning as "en-US", when it should be "en-GB". I have checked the identity that the application pool is running as and the location settings within Control Panel (and registry settings) are set to en-GB / UK.

I have tried adding <globalization uiCulture="en" culture="en-GB" /> to both the web.config located in the ISAPI folder and the web.config located in the Web Application virtual directory, but this hasn't had any effect either.

Can I make any changes that would have SharePoint and the web service run under the en-GB culture?

0

It appears I had tried to change the regional settings everywhere with the exception of within the actual site settings (the existence of which I was unaware, previously assuming that regional settings would be based on the server settings of the farm).

Once changed on the site (via Site Settings - Regional Settings), the web service picked up the correct culture.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.