2

By default, all the lists here are auto-expanded (see red squares on screenshot), I'd like to have them NOT expanded by default, how can I achieve that ?

screenshost list

Edit: I went in the options posted by some answers below and it's already on "Collapsed", what the?

screenshot collapsed

4
  • Have you selected "Collapsed" in the view settings? Aug 27, 2014 at 13:40
  • See edit and new screenshot, it's already set to "collapsed", any other ideas ? Aug 27, 2014 at 13:49
  • I frequently have issues with things being properly collapsed or not; it seems to be because sharepoint tries to remember the state of each group you collapse or expand as you navigate around the site... try setting it to collapsed, close your browser completely, clear the cache, and come back. Also interestingly, I find that if you have it set to collapsed and everything is expanded, selecting expand will usually collapse everything on the next page view
    – John-M
    Aug 27, 2014 at 13:56
  • ^^ Doesn't seem like it, I tried with Chrome in Incognito mode and it's still all auto expanded. Aug 27, 2014 at 13:59

5 Answers 5

3

Try this one:

From Ribbon click on Modify view. on this page go to group by and you will see this

options By default, shows groupings

see the screen shot.

enter image description here

4
  • already set to that... still it's all expanded. Aug 27, 2014 at 19:30
  • do you have any customization on page, any javescript or etc?
    – Waqas Sarwar MVP
    Aug 27, 2014 at 19:40
  • Nothing really, there is some html code involved for some indicators but nothing biggy. Aug 28, 2014 at 13:24
  • ok to corner the issue....can you create another list in differnt site collection and test it. also different browser and may be differnt pc & user
    – Waqas Sarwar MVP
    Aug 28, 2014 at 19:44
2

Having the same problem, except I want my list expanded by default. Tried something from one of the comments above and it worked. If you have the modify view set to collapsed and everything is expanded manually, selecting expand will usually collapse everything and visa versa. So I set modify view setting to collapsed, then collapsed my list manually. Then. when I changed the modify view settings to expanded, it worked.

1

There is such an option in the group by block in the create view called " By default, show groupings: collapsed or expanded"

1
  • already set to that... still it's all expanded. Aug 27, 2014 at 19:30
0

This is an old question, but someone running Sharepoint online modern sites might come here anyway, like I did :)

Non of the above answers worked for me list until changed: Edit current view --> Enter a large number for "Number of group to display per page". Entering 500 there made the list stay collapsed. enter image description here

-1

As crazy as it sounds I read Bobby's answer over and over, but now my View Group By is set to Collapsed and the View loads as expanded just like I wanted!

Basically set it to what you want manually -- because it WASN'T behaving, and then toggle the status. So even if the status is set to collapsed it will appear expanded. Or visa-versa.

1
  • Why vote this down. I clarified an answer that was very difficult to read but provides a solution!
    – alar
    Nov 23, 2017 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.