1

We just moved our Sharepoint (2010 Enterprise) SQL databases to another machine. Sharepoint is all running well,

however, in the Windows Server (2012 R2) application logs, I am seeing this recurring error:

Tracing Service failed to create the trace log file at location specified in SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\14.0\WSS\LogDir. Error 0x0: The operation completed successfully. . Traces will be written to the following directory: C:\Users\SHAREP~2\AppData\Local\Temp\.

The failing service has the category of Unified Logging Service, and the source is SharePoint Foundation.

Now, since that is a registry key, I went and looked it up and found it to be:

%CommonProgramFiles%\Microsoft Shared\Web Server Extensions\14\LOGS\

When I type that into Explorer, it resolves to

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\

But if I type that into a 32bit file-explorer, it will (as expected) resolve to:

C:\Program Files (x86)\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\

But the latter directory does not exist. So, since whatever is causing the Error Log entries can't find the directory that doesn't exist, that tells me that it is a 32bit application trying to use a 64bit environmental variable.

My question is, since Sharepoint is 64bit, why is Sharepoint using a 32bit application for logging? Actually, my question is, "How do I get this error to go away (without replacing the environmental variable in the registry key)?"

[update]

Does anyone have any clues here (or at least a +1 for support)?

When I try to use MS's ULS viewer, with the path of the uls logs set to \\saintmagnus\c$\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS like they should be, nothing gets loaded.

Also, I tried manually changing the registry key to C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS\ to leave out the environmental variable, but it didn't make any difference (maybe I need to restart something to get that to take?)

So the logs are being written to C:\Users\SHAREP~2\AppData\Local\Temp\. I can load them in the ULS viewer from there, but that's not the right place.

So I make sure that the right LOGS folder has modify/read/write permissions set for the farm account.

Why???? What can I try here?

1

Okay, I went and made sure what account was attached to the SPTrace Service. You can find out by looking in Services.msc for SPTrace. It was not the same as the farm account.

Since I am using a domain account for this service (it is a Managed Account in Sharepoint Central Admin) and not a local account, then it needs the proper rights.

So I went and gave read/write/modify rights to the LOGS folder (correct path) to this account.

As soon as I did this, Sharepoint began writing the log entries to the correct location.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.