1

I customized the standard Shared Documents library in the following ways:

  1. Renamed the "Title" column to "Description"
  2. Added new columns to the default view ("All Documents")

The Description column is showing up on the All Documents view and when creating or editing a view. I was also been able to create a new Datasheet View and select the Description column, but the Description column was still not showing up like one the 2nd screenshot below.

However, it's not showing up anywhere else: Edit in Datasheet, Edit Properties, Settings > Columns, etc. I checked for the column in these and other places, but I don't see it anywhere.

Any suggestions why this is happening and how I can get the Description field to show up, particularly for editing?

See the screenshots below.

All Documents

All Documents view

Datasheet View

Datasheet view

Edit Properties

enter image description here

Settings > Columns

enter image description here

Settings > Columns > Add from existing site columns

enter image description here

  • @WaqasSarwarMCSE Thanks for the link. We have Office 2010 on the machines. Also, one of commenters says "...all columns disappearing allow multiple values". My Description field is a single-line text field. Plus, I can't find Description anywhere else, not just on Datasheet – ulmas Aug 21 '14 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.