2

I am trying to connect client.svc and getting below error

"The server encountered an error processing the request. See server logs for more details."

ULS is giving below two error,

System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Data.Edm, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. File name: 'Microsoft.Data.Edm, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Data.OData, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. File name: 'Microsoft.Data.OData, Version=5.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

Thanks in advanced.

2

It looks like you are missing WCF Data Services 5.0 for OData V3. Install it from here and reset IIS (may have to restart your machine):

http://www.microsoft.com/en-us/download/details.aspx?id=29306

I have seen this happening on dev machines having both Visual Studio 2012 and 2013 running side-by-side, and then uninstalling VS 2012 and related components.

  • Yes you are right. Sorry for not to updating the answer. This happen to me when i installed VS2013 and uninstall older version. – Ravi Khambhati Dec 8 '14 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.