I'm following this Branding example - Creating the Branding101 Project

When I get to the Deploy, I get this error in Visual Studio

Error occurred in deployment step 'Add Solution': Unable to load assembly group. The user assembly group provider threw an exception while trying to provide user assemblies for the specified assembly group.

In the SharePoint Logs I get this...

-  - Unable to load assembly group. The user assembly group provider threw an exception while trying to provide user assemblies for the specified assembly group. - Assembly group id: ", GroupId = "6F4390B205E741A99987A7E415C6A35F-/IYL9cV+BAGCtKagtmUoEKm28+0/iaIbJdAbSB5L6og="" - Inner Exception: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))    
 at Microsoft.SharePoint.Library.SPRequest.GetListsWithCallback(String bstrUrl, Guid foreignWebId, String bstrListInternalName, Int32 dwBaseType, Int32 dwBaseTypeAlt, Int32 dwServerTemplate, UInt32 dwGetListFlags, UInt32 dwListFilterFlags, Boolean bPrefetchMetaData, Boolean bSecurityTrimmed, Boolean bGetSecurityData, Boolean bPrefetchRelatedFields, ISP2DSafeArrayWriter p2DWriter, Int32& plRecycleBinCount)    
 at Microsoft.SharePoint.SPListCollection.EnsureListsData(Guid webId, String strListName)    
 at Microsoft.SharePoint.SPListCollection.Undirty()    
 at Microsoft.SharePoint.SPBaseCollection.GetEnumerator()    
 at Microsoft.SharePoint.SPWeb.GetCatalog(SPListTemplateType typeCatalog)    
 at Microsoft.SharePoint.Administration.SPSolutionLanguagePack.GetSolutionInfoFromGallery(Guid siteId, Guid solutionId, String solutionHash, String& fileName, String& hash, Byte[]& fileBytes)    
 at Microsoft.SharePoint.UserCode.SPUserCodeLightweightSolutionAssemblyGroupProvider.GetAssembliesInGroup(Guid siteId, String assemblyGroupId)    
 at Microsoft.SharePoint.UserCode.SPUserCodeAssemblyCacheManager.EnsureUserCodeAssemblyGroupIsCached(Guid siteId, SPUserCodeAssemblyGroupId userCodeAssemblyGroupId)

Can someone help me with deploying this test solution?

The only difference between the example and my solution was I had create a new web application on port 33333 and created a new blank site. I just changed to deploy to port 80 and it worked. I would still be interested if there is an explanation for this though. I guess there must be some difference between the web app I created on 33333 and the defautl one created at 80.

  • If you scroll over a bit, you see that your actual error is "Access is denied." so it has to do with your permissions
    – Dave Wise
    Apr 14, 2011 at 13:30
  • Do both port 80 and 33333 use the same application pool?
    – Dave Wise
    Apr 14, 2011 at 23:04

4 Answers 4


Have you tried restarting the sandboxed code service?

Check what account and permissions your sandbox code service is running under.

  • 1
    I had restarted the service... do I check the account and permissions through SP admin or elsewhere?
    – user3043
    Apr 14, 2011 at 13:31
  • Should be in CA->Security->Service Accounts
    – SPDoctor
    Apr 14, 2011 at 13:44

The sandboxed service unpacks the DLLs of a sandboxed solution when the solution is first accessed and caches them in a subfolder at C:\ProgramData\Microsoft\SharePoint\UCCache. On each subsequent access of the same solution, they are retrieved from there. If a server goes a while without a request for that solution, the subfolder is deleted. I wonder if the user account under which the sandboxed service is running has rights to that folder.


The Microsoft SharePoint Foundation Sandboxed Code Service runs with a specific account. Add this account to the web application (you’re using to deploy the solution) in Central Administration, User Policy, with full control. Perform an iisreset afterwards.


Also stumbled over this yesterday, this article helped me : http://williamvanstrien.blogspot.com/2011/04/error-unable-to-load-assembly-group.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.