4
  1. I have installed SharePoint Prereq in an offline mode and all the configuration running well
  2. I have configured AppFabric and connect it to SQL Database
  3. The IIS identify the AppFabric and the AppFabric 3 services running and started
  4. When i am trying to install SharePoint 2013 on Windows server 2012 an error massage say that AppFabric not configures try to UN install it and install it again !!
  • did you install the app fabric as part of pre-req or you installed it manually? – Waqas Sarwar MVP Aug 18 '14 at 13:22
  • i install it manually at first then run the prerequisiteinstaller.exe and all successful , system restat then trying to install SP2013 an error massage say AppFabric not configures try to un install it and install it again. – Helmy Mohamed Aug 20 '14 at 6:58
8

Looks like you install the pre-req offline / manual.

This was caused by manually double clicking the file “WindowsServerAppFabricSetup_x64.exe” instead of allowing the SharePoint Prerequisite Installer to run this.

The resolution was to run “prerequisiteinstaller.exe” with command line parameters to directly specify the filename for each prerequisite.

/AppFabric:prerequisiteinstallerfiles\WindowsServerAppFabricSetup_x64.exe
/KB2671763:prerequisiteinstallerfiles\AppFabric1.1-RTM-KB2671763-x64-ENU.exe

Here are steps:

Uninstall first.

enter image description here

Now run the commands.

enter image description here

http://www.spjeff.com/2012/07/19/fixed-sharepoint-2013-setup-error-appfabric-is-not-correctly-configured/

  • if this solve the problem, than mark it answer other will get advantage of it. – Waqas Sarwar MVP Aug 20 '14 at 13:11
  • In my case was necessary to copy the AppFabric .exe files on the prerequisiteinstallerfiles folder of the unziped version of the image with the Sharepoint 2013 installation (If you dont have the iso, you can download the iso of the Sharepoint 2013 server edition on msdn.com). Everything is OK now. Thanks everybody. – Adrian Feb 12 '18 at 12:15
4

In my case prerequisiteinstaller.exe went into a loop for the very last prerequisite: KB2671763. Installation failed over and over again. The prerequisite installer log file didn't help much, almost seemed as if there were omitted lines.

The patch log (C:\ProgramData\Microsoft\E-Business Servers Updates\Updates\Uninstall2671763\setup.log) itself contained an error message like:

failed to copy the .msp file

Before getting a correct resolution, I tried simply applying the .msp, but it was clear that although the versions of core files were updated, the patch was not complete.

For example, the expected registry entry missing at:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\E-Business Servers Updates\{96E70525-4CD1-4920-9C0B-91055C79A962}

Because of the only-partly-successful patch, I uninstalled AppFabric 1.1 completely and reinstalled manually using the manual command line in an elevated prompt:

WindowsServerAppFabricSetup_x64.exe /i CacheClient, CachingService, CacheAdmin /gac

The installation succeeded. TechNet gives this as the way prerequisiteinstaller.exe installs AppFabric, apologies for having lost the link, but you can find it I'm sure.

I rebooted and ran AppFabric1.1-RTM-KB2671763-x64-ENU.exe manually from an elevated command prompt. First the patch put up a messagebox about "failed to copy the .msp file" (as mentioned above).

After clicking Retry it succeeded. Everything showed up where it is supposed to be, and the log file showed success as well.

Summary

For SharePoint 2013 SP1 on fully-patched to 11/26/2014 Windows Server 2012 R2, prequisiteinstaller.exe apparently will not work, because it will not retry the initial failed copy operation during installation of AppFabric 1.1 CU1.

Why the copy fails the first time, and succeeds the second time when the Retry-button available, I cannot explain.

Credits go to spjeff and rafael and everyone else in this post for putting me on the road to successful prerequisite installation.

  • When installing AppFabric via command prompt I am getting a command line syntax error: Duplicate command line argument. Paramtere name: install - Why is that happening? ... Edit: Answer ist to remove the space between CacheClient, CachingService, CacheAdmin. – Florian Leitgeb Jan 25 '17 at 11:11
0

I ran into this problem myself. If you are installing offline then you HAVE to let the prereq installer install the appfabric. The installer also does some behind the scenes configuration that is vital for sharepoint to install properly. If you install the appfabric manually then that configuration work doesn't get done and Your installation will fail.

  • 1
    ok system restart now after using the CMD way of installation thanks. – Helmy Mohamed Aug 20 '14 at 7:13
  • That is not true. You can defenitely do the prerequisites installation without the native installer. Just use the command line for AppFabric like described by mike. – Florian Leitgeb Jan 25 '17 at 13:14
0

I have the same issue. the following solution resolved my issue:

The issue can be caused due to the following:

  1. The path to the PowerShell executable that is needed for the AppFabric installation is incorrect.
  2. In some scenarios, repeated uninstallation and re-installation does not fix the issue. This is because the installer does not remove the PSModulePath entry in Environment Variables during un-installation and the installation fails because the entry already exists.
  3. If you are trying to install all the prerequisites manually as the server does not have a connection to internet.

Note: Appfabric installation and configuration has to be done by the prerequisite installer ONLY and not in a stand-alone manner.

You can implement any one of the two solutions listed below

Solution 1

Append the following path to PSModulePath entry in the environment variables – %SYSTEMROOT%\System32\WindowsPowerShell\v1.0

  • Go to My Computer, right-click Properties
  • On the System page, click Advanced System Settings on the left-side pane.
  • If you receive a UAC prompt, click on Yes to launch the System Properties dialog box
  • From the Advanced tab, click Environment Variables
  • Within the System Variables section in the lower half, select PSModulePath and click on Edit (or double-click PSModulePath)
  • Append the following path to PSModulePath entry in the environment variables

    %SYSTEMROOT%\System32\WindowsPowerShell\v1.0\

  • Ensure that the PSModulePath entry looks like this:

    C:\Windows\system32\WindowsPowerShell\v1.0\Modules\;c:\Program Files\AppFabric 1.1 for Windows Server\PowershellModules

0

I would suggest to do all windows updates before, then you have to do less manually.

First make sure all necessary features are enabled and installed. To do so, insert Windows Server install disc and execute this command:

# Edit the drive letter that has your Server 2012 R2 media.
$drive = "E:"

Import-Module ServerManager

Add-WindowsFeature NET-WCF-HTTP-Activation45,NET-WCF-TCP-Activation45,NET-WCF-Pipe-Activation45 -Source $drive\Sources\sxs

Add-WindowsFeature Net-Framework-Features,Web-Server,Web-WebServer,Web-Common-Http,Web-Static-Content,Web-Default-Doc,Web-Dir-Browsing,Web-Http-Errors,Web-App-Dev,Web-Asp-Net,Web-Net-Ext,Web-ISAPI-Ext,Web-ISAPI-Filter,Web-Health,Web-Http-Logging,Web-Log-Libraries,Web-Request-Monitor,Web-Http-Tracing,Web-Security,Web-Basic-Auth,Web-Windows-Auth,Web-Filtering,Web-Digest-Auth,Web-Performance,Web-Stat-Compression,Web-Dyn-Compression,Web-Mgmt-Tools,Web-Mgmt-Console,Web-Mgmt-Compat,Web-Metabase,Application-Server,AS-Web-Support,AS-TCP-Port-Sharing,AS-WAS-Support, AS-HTTP-Activation,AS-TCP-Activation,AS-Named-Pipes,AS-Net-Framework,WAS,WAS-Process-Model,WAS-NET-Environment,WAS-Config-APIs,Web-Lgcy-Scripting,Windows-Identity-Foundation,Server-Media-Foundation,Xps-Viewer -Source $drive\Sources\sxs

You have to execute the AppFabric Installation via command line like described by mike:

WindowsServerAppFabricSetup_x64.exe /i CacheClient,CachingService,CacheAdmin /gac

Then make the CU1 for AppFabric via normal installer and also install the rest of prerequisites you need.

Here is a list with all other necessary download links for the prerequisites files: click me

No native Prerequisites Installer needed!

0

This issue is as a result from some security in IE. To fix it go to open internet browser, Internet options, Security, Click Custom Level and enable file download. Next Step. Click on server manager (2012 and 2016), Local Server, IE Enhanced Security Configuration and turn it off

It will fix the issue

  • This issue happened because user first installed the AppFabric Manually. It needs to be installed by pre-requisite installer as the SP App Fabric set up is quite specific. – Marek Sarad Aug 31 '18 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.