0

So I created a new single farm SharePoint server for testing purposed (we currently had a live production farm but no testing server). I am trying to restore the back ups of the live server to the back up so proper testing of migration and security can be done.

When I run the power shell script I get hit with the following error:

Restore-SPSite : Your backup is from a different version of Microsoft SharePoint Foundation and cannot be restored to a server running the current version. The backup file should be restored to a server with version '14.0.0.6106' or later.

After looking into the config settings of the destination server I see that the version I am running is 14.0.6029.1000

My questions are

1) Isn't 14.0.6029.1000 a later version of 14.0.0.6106?

2) If it is, do I have to downgrade the testing server to match the original production server?

3) are there any other reason this error could be thrown?

Thanks in advance!

1

What i understand your Production Farm's Build # 14.0.0.6106 and destination is 14.0.6029.1000, correct? also verfiry from central admin from both farm.

  1. 14.0.6029.1000 is the Sp1 level while 14.0.0.6106 June CU 2011
  2. you dont need to downgrade the testing server rather upgrade it to june 2011 CU.
  3. Version mismatch is the only reason error.
  • thanks for the info! I will start looking into upgrading it to the mentioned CU. – Jeffrey Quinn Aug 14 '14 at 21:05
0

At times when Restore-SPSite PowerShell commands fail, the STSADM commands have worked for me occasionally. You could give it a shot.

stsadm -o restore -url "siteurl" -filename "backupfilename"

That being said, as rightly pointed out by Waqas, upgrading the environments to the right CU is the recommended option.

If interested, you can check out few more options that I have blogged here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.