1

When I check service connection of my web app, I found the "Workflow Service Application Proxy" wasn't in default group. I want to check but it was disabled.

How can I add it to default group?

1

You need to register it as Register-SPWorkflowService cmdlet automatically adds the Workflow Service Application Proxy to the Default proxy group

For HTTPS site

Register-SPWorkflowService -SPSite 'https://myhost/mysite' -WorkflowHostUri 'https://WorkFlowServer.domain.com:12290' -AllowOAuthHttp –Force

For HTTP site

Register-SPWorkflowService -SPSite 'http://myhost/mysite'  -WorkflowHostUri 'http://WorkFlowServer.domain.com:12291' -AllowOAuthHttp –Force

You will have to Re-Register after installing March or any later update (2013).

Notes:

The Register-SPWorkflowService cmdlet creates a Workflow Service Application and associated Service Application Proxy which connects the SharePoint farm with Workflow Manager. The cmdlet automatically adds the Workflow Service Application Proxy to the Default proxy group in SharePoint. If you are using a custom proxy group then you will need to add the Workflow Service Application Proxy to the custom group manually using either the Central Administration interface or the Add-SPServiceApplicationProxyGroupMember cmdlet.

you can try by using Add-SPServiceApplicationProxyGroupMember cmdlet follow below article: http://technet.microsoft.com/en-us/library/ff607588(v=office.15).aspx

0

yes, Anuja is perfectly right. In your case, it seems, you registered for another service connection group. Adding the workflow service proxy via checkbox in Central admin to group "default" is not possible.

You can find here a sample code snippet how to add via PowerShell:

Do I have to run Register-SPWorkflowService for each site collection?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.