2

I have a publishing site on SP 2013. When viewed with Firefox, users get a message:

Allow site.xzy.com to run "Microsoft Office?

How do I disable this?

I thought this was the "client integration" setting, and have already disabled that, but the message still appears.

edit: as noted below, I want to disable this so it doesn't appear for any users. It's a publishing site, and users will not be interacting with office docs of any kind.

  • As Moe mentioned, to disable this alert You need to always active the Microsoft Office 2013 15.0.4420.1017 Plugins. The plugin allows you to have a better experience with Microsoft SharePoint. – Waqas Sarwar MVP Aug 14 '14 at 3:56
  • This is a publishing site that will be viewed by non-employees. I don't want a permissions pop up confusing and distracting the users. And I don't want to have to send out a message to 1000 non employees with special instructions so they can view a website. Again, it's just a publishing site; they will not be using any MS office functionality by design. – Mike2500 Aug 14 '14 at 13:06
  • I dont think then you can do this...The only place you can get the anwser is Contact MSFT support for this. – Waqas Sarwar MVP Aug 14 '14 at 13:43
3

Got it. Add the following script to the head to override the functions that add the activex:

//get rid of name.dll reference 
function ProcessImn() { }
function ProcessImnMarkers() { }

source: http://www.greggalipeau.com/sharepoint-public-facing-remove-plugin-prompt/

1

Activate the plugin from the browser's plugin settings. Use Always Activate option. There's a similar thread on MSDN with a picture.

  • Thanks, but I want to disable it so this message doesn't appear for anyone. It's a publishing site; users will not be interacting with office docs at all. – Mike2500 Aug 13 '14 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.