0

I'm working on migrating to Sharepoint 2013, and have been encountering the same issue for some time now. I've found a 'Fix', but worry that there may be a greater underlying issue I need to resolve.

The basic issue is with the 'Default' Style in Sharepoint 2013. When I create a library using the 'Default' style I'm unable to open any of the documents in the Library, it throws this error:Error thrown in default view

Now, if I change the style to 'Shaded' I'm able to download the files and everything acts [mostly] as I would expect it to. Except for minor annoyances that have been documented elsewhere enter image description here

Any suggestions as to why the error would be getting thrown in one style but not in another? I'm a bit at a loss as to why a file wouldn't be able to be found in one style, but not another.

If no other solution can be found, can anyone perhaps point me in the right direction to change the 'Default' view to default as the 'Shaded' view. Saving me from having to manually change every library as we Migrate?

0

The reason why is simple, the first style is using different functionality than the other. Functionality that is not available to SharePoint at render time for some reason.

In other words, you're missing a reference to a javascript file or the sequence of loading javascript files is broken.

I took a quick look throughout SP.JS and can see where it's being referenced but I don't know where this function is originating from.

Is it possible for you to change the masterpage to one of the Out of the box masterpages? Seattle or Oslo?

  • It was already set to Seattle, changing it to Oslo doesn't seem to change the issue – Kandirma Aug 13 '14 at 15:13
  • Could you try creating a new view for your library – Christoffel de Gruyter Aug 13 '14 at 15:15
  • Creating a new view is basically what I did Initially. The only setting that needs to be changed for it to 'work' is change the "Style" option to anything BUT "Default". I'd settle for a way to bulk change all libraries, present and future, to 'Shaded' but it's less than ideal. – Kandirma Aug 13 '14 at 15:28
  • Don't have the time right now to do this myself, but there's probably a very easy solution for fixing this. Someone just needs to go through the JS files and find the function that you're missing (getctxrgiidfromIid). Then just make sure that javascript file is referenced in the masterpage and you should be good to go. If I have some time I'll go through it. – Christoffel de Gruyter Aug 13 '14 at 15:49
  • I appreciate it - I'm not opposed to going through them myself I just a.) Don't know where they actually are b.) Didn't figure that was the issue since changing styles 'miracuously' fixed the issue. - suppose each style uses different Java Script files. – Kandirma Aug 13 '14 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.