0

I recently was looking to change the search results page for person results. I opened Design Manager, grabbed the URL that it said to map to, and tried mapping in Windows Explorer. After clicking finish, an error message pops up:

The mapped network drive could not be created because the following error has occurred: A device attached to the system is not functioning.

The weird thing is, I can open Sharepoint designer just fine and open sites from there. Likewise, I can open Word, specify that I want to save to a Sharepoint site, enter in the exact same URL, and the explorer window that pops open is the directory I'd like to save to.

I have rebooted both the server and the client machine and still get the error. The server has the Desktop Experience feature installed. The server is using SSL. Is there anything else I can check to get this to work?

Update

Still no luck. Here's some background that I'm going to illustrate so others who run into the same issue might find useful. First, this farm started out as plain HTTP. We mapped folders fine before, so I'm sure this has to do with SSL. When we switched, we purchased SSL certificates that point to fully qualified domain names that the servers respond to. The SSL certs are installed, the servers display Sharepoint over SSL just fine, etc.

When I try to map to the FQDN at the command line:

net use https://mydomain.isawesome.com

I get the error System error 64 has occurred.

The specified network name is no longer available.

When I capture the network traffic in Fiddler, I get this:

HTTP/1.1 200 Connection Established FiddlerGateway: Direct StartTime: 11:55:44.094 Connection: close

Nothing else. I don't have anything in my event viewer on the client or the server. I found this link that describes the following answer:

IIS is not installed or is not running on the server that you are attempting to connect to.

•You have not installed the WebDAV Redirector on your client system.

•The WebClient service is not running on your client system.

•You have not enabled WebDAV on your web site.

•You are using Basic Authentication and connecting to your web site using HTTP instead of HTTPS.

•You are connecting to a web site on your local network that is using Fully-Qualified Domain Names (FQDNs) for name resolution, your web site uses Windows Authentication, and you have not added the web site's FQDN to the proxy server bypass list on your client.

•You are connecting to a web site via SSL, but the security certificate presented by the website is issued for a different website's address or the security certificate is revoked.

For my situation, IIS is running. WebDAV is installed on the server, the webclient service is running on our machines, the server has the webdav redirector installed, we are using Windows Auth / Claims, we are not using Basic Auth, we do not have a proxy server and the server is using the correct certificate.

Are there any debugging tools that could be turned on to further help figuring this problem out?

  • This is your own personal server? Or are there some devices in between? – Christoffel de Gruyter Aug 13 '14 at 14:11
  • It is our web front end server in our server farm. – jkandiko Aug 13 '14 at 14:26
  • Try one thing. Launch Fiddler2 with the Fiddler2 SSL loaded and try then. I have found that if it works after that, then it is something on the server side but if it doesnt work than it can be something on your workstation. Have you tried to map the drive from another workstation? – Funi Magnússon Aug 13 '14 at 23:14
  • When I try from a different machine, I get 'Network Name Cannot be Found'. It's weird, it is the full https address that pulls up just fine in the browser. – jkandiko Aug 15 '14 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.