Recently I have Installed SharePoint SP1 (15.0.4571.1502)

I have Create a New Web application and SC with BI Center Template.

Activated the Report Server integration feature and deployed PowerPivot Web Application Solution. Now When I wanted to Add SSRS Content types to Data Connections Library, I cannot see them. They are missing in Site content Types.

enter image description here

However I was able to add Report Data Source by copying the Create Report Data Source Link from the Old Site Address and Replaced with Current Site and was able to save it to the Data Connections library. Still cant see the content Types.

enter image description here

I have old BI center Web Site which has SSRS Content types. This was created before installing the SharePoint SP1, they are still visible and I can add or remove them.

enter image description here

Not sure if the SharePoint 2013 SP1 has a Bug or if I am doing something wrong.

Installed the SP1 and Ran the Config. And was reported Successfully Installed. Any input will be helpful.

  • Finally This is fixed by doing the following steps in this order only 1. Installed SharePoint SP1 2. Run PSconfig 3. Install windows update and Restart 4. check for updates again and install if any 5. Install Microsoft® SQL Server® 2012 SP1 Reporting Services Add-in for Microsoft® SharePoint® ( microsoft.com/en-us/download/details.aspx?id=35583) At this stage SSRS content types showing up again. – Manoj Manda Sep 5 '14 at 19:08

Finally This is fixed by doing the following steps in this order only(Tested Multiple farms)

  1. Installed SharePoint SP1

  2. Run PSconfig

  3. Install windows update and Restart

    1. check for updates again and install if any

    2. Install Microsoft® SQL Server® 2012 SP1 Reporting Services Add-in for Microsoft® SharePoint® ( http://www.microsoft.com/en-us/download/details.aspx?id=35583)

At this stage SSRS content types showing up again.

  • Which command line parameter did you use for execution of PSConfig if you don't mind me asking? – Darek Oct 8 '15 at 20:38
  • I just used SharePoint 2013 Products Configuration Wizard. – Manoj Manda Oct 15 '15 at 21:38

Edit: I'm not certain if it's a bug or misconfiguration on my end. If you don't see SSRS content types make sure you exhausted all the other solutions (like installing SSRS addin again or making sure the "Report Server Integration feature" is turned on at site collection level etc before you try the solution below). If you do follow the steps below to add SSRS content types make sure to deactivate and active 'Report Server Integration Feature" from the site collection level before you add these content types to Lists or Libraries.

This seems to be a bug with SP1. We've experienced the same problem with SharePoint 2013 + SP1. Fortunately we had an old site collection that still had SSRS content types so I was able to reconstruct them in new site collections as follows.

  1. Go to Gear > Site Settings > Site Content Types and click Create.

  2. For Report Builder Model content type, use the following settings:

    • Name: Report Builder Model
    • Description: Create a new Report Builder model.
    • Select parent content type from: Document Content Types
    • Parent Content Type: Document
    • Put this site content type into: New Group > SQL Server Reporting Services Content Types
    • Click OK and in the next screen, click Advanced Settings and in Enter the URL for an existing document template use /_layouts/15/ReportServer/NewReportBuilderModel.smdl and click OK
  3. For Report Builder Report content type, use the following settings:

    • Name: Report Builder Report
    • Description: Create a new Report Builder report.
    • Select parent content type from: Document Content Types
    • Parent Content Type: Document
    • Put this site content type into: Existing Group > SQL Server Reporting Services Content Types
    • Click OK and click Advanced Settings and in Enter the URL for an existing document template use /_layouts/15/ReportServer/rs.rsapplication and click OK
  4. For Report Data Source content type, use the following settings:

    • Name: Report Data Source
    • Description: Create a new report data source.
    • Select parent content type from: Document Content Types
    • Parent Content Type: Document
    • Put this site content type into: Existing Group > SQL Server Reporting Services Content Types
    • Click OK and click Advanced Settings and in Enter the URL for an existing document template use /_layouts/15/ReportServer/NewSharedDataSource.rsds and click OK
  • Thanks Venkatesh! I have fixed this by following the below steps – Manoj Manda Sep 5 '14 at 19:10

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.