4

I have a custom list (clicked together on the portal site, so no custom templates) in which attachments were disabled and afterwards re-enabled. The "Attach file" action menu item does however not re-appear on the New/Edit forms. No other customizations are done by the key-user since they have no access to SharePoint Designer or Visual Studio. Is there a way to get this functionality working again?

  • Does this happen on editing all items that were created before and/or after attachments was re-enabled? – Eric Schrader Apr 13 '11 at 16:51
  • Every single one (created before and after). Note that all existing attachments were removed when disabling attachments. – Bart Apr 13 '11 at 16:53
1

I can't recreate this issue using a custom list, it seems to work fine for me or though I don't really understand what do you mean by clicked together ?

  • I mean it's created in SharePoint itself, not defined in a list definition and deployed in a feature. I wasn't able to reproduce it myself with another list either. – Bart Apr 20 '11 at 11:04
  • 1
    Weird :s, How about resetting the page to site defenition? I know you said that hasn't been modified but is nothing to lose on trying. To do this go to site actions > site settings, under look and fill click Reset to site definition and type the full url for your page. – Renzo Apr 20 '11 at 11:10
0

make sure no web parts were added to the form pages using the toolpaneview=2 trick

0

I recently picked up this project again (since it just had to be finished after all :)), and I found out what caused the attach file button to disappear when I recreated the list they left me from scratch.

If you try to use a calculated field with a reference to [Today] or [Me] you get a nasty error message which prevents you from making the column.

Calculated columns cannot contain volatile functions like Today and Me

Now if you think you're smart, you can create a column Today, enter the formula in the calculated field and remove the column Today. Tadah, it 'works'. Now go try and make a new item and the upload attachment button might be gone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.