1

I've created a new site collection in Central Admin on my SharePoint server. However when I type in the new site URL I get the "Sorry, this site hasn't been shared with you." Is there a way to share the site with myself through Central Admin?

My user account has the following settings on Central Admin:

  • Farm Administrator
  • Primary Site Collection Administrator (of the site I'm trying to access)
  • In Application Management\Manage web applications\User Policy - my user account has full control

I should note: I created a site a while back and I could go to the URL and add doc libraries and lists etc. but I've somehow lost the ability to do so? So I did have access at one point. I don't know what change was made to restrict that.

I'm new to sharepoint so any help is appreciated.

Thanks!

3

Thought I'd post an update as the problem has been resolved.

When I was troubleshooting I deleted and recreated multiple site collections to see if it made any difference - it did not.

Finally I gave up, deleted my original web application on port 80 and recreated it. Added a site collection. And configured the permissions on that webapp.

The new web app works perfectly. Not sure what exactly went wrong with the previous one, but my solution was to rebuild from scratch.

It is working as should, I can share the site with other users and build off of it.

Thanks everyone for your help.

  • I've noticed this a lot with SharePoint 2013. Sometimes the best way to get it working is to re-create the web application and site collection. – contactmatt Feb 20 '15 at 18:08
1

Try the following:

SharePoint 2010 / 2013: Access Denied to claims web apps

Excerpt from the article:

Cause

In the Local Security Policy | Local Policies | User Rights Assignment, “Bypass traverse checking” -- did not have the “Everyone” or “Users” group listed here, or anything that would contain the IUSR account. Because IUSR did not have this permission, it could not traverse C:\inetpub\, or C:\inetpub\wwwroot\, etc to get to C:\inetpub\wwwroot\wss\VirtualDirectories\80, and therefore was showing access denied for that directory even though it had permission at that level.

Resolution

  1. Add a group that contains IUSR to “Bypass traverse checking” in the Local Security Policy. This could be “Everyone”, or “NT Authority\Authenticated Users”, or “Users”.
  2. Gpudate /force
  3. IISReset Note: These policies may be pushed down to the machines via GPO, so you may have to change it at that level.
0

Couple of things to check.

  • What authentication method you are using, ADFS, Claims or FBA. and make sure correct account added into the primary site collection admin.
  • Create another site collection and test it.
  • try to access the site collection via farm admin account.
  • Make sure you configured the Object Cache setting for your web app correctly. three things involved in it, add user into Policy of web app, run powershell to update and reset IIS on all servers. more details about how to configure it here: http://technet.microsoft.com/en-us/library/ff758656(v=office.15).aspx... most access denied of wrong configurtion of Object cache.
  • 1) Authentication method=Claims, 2) Create another site= Tried that and tested multiple times - same result, 3) How do I test this? It does not prompt me for credentials when I go to the URL? 4)Are the securityadmin and db_owner accounts necessary to make this work? All other settings are as should (my user account has Full Control) – monicaaa Aug 8 '14 at 22:37
  • Now couple of things to check...1) when you login on your pc/ server which account you are using? is the same account is primary admin account or not? try to login with different account which you can do via url hack...siteurl/_layouts/… with farm admin account. – Waqas Sarwar MVP Aug 9 '14 at 3:11
  • to check the Object cahce configuration....run this powershell...$wa = Get-SPWebApplication -Identity "<WebApplication>" $wa.Properties["portalsuperuseraccount"] $wa.Properties["portalsuperreaderaccount"] after that make sure same account added intot he policy of web app. – Waqas Sarwar MVP Aug 9 '14 at 3:12
  • 1)Same account as primary admin account. 2)What is the template for the URL hack? ...siteurl/_layouts/<farm admin account name>/ ? – monicaaa Aug 12 '14 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.