2

How can I disable the preview of the document on the mouse-over in a search result web part?

6

I solved using CSS:

.ms-srch-hover-outerContainer
{
    display:none !important
}
|improve this answer|||||
  • where do you put that css inside the Display Template (Default Result web page) ? – Luis Carvalho Nov 12 '14 at 10:04
  • you should create a your custom search page and add that CSS – Nk SP Nov 12 '14 at 10:07
  • You mean the "searchresults.aspx"? What about the document previews on the document libraries. I need to disable there also. – Luis Carvalho Nov 14 '14 at 9:07
  • got it by going to: Site Settings| Site Master Page Settings. There just select the "option specify a CSS file to be used by this site and all sites that inherit from it". link your uploaded css file – Luis Carvalho Nov 17 '14 at 11:10
2

If you are looking for a global solution, I don't think one exists. The behavior is controlled by the display template for the result.

The hover behavior on the Display Template is controlled by JavaScript and a hidden div on the Display Template. You can do any number of things to disable this. Edit the display template and remove the onmouseover event handler is probably the easiest way.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.