5

I installed SharePoint 2013 on fresh windows server 2008 R2 SP1 in standalone mode. SharePoint prerequisites installed automatically from net. After I configured SharePoint, My Distributed Cache Service was stopped and I cannot start it.

I searched in google and I found this and other links that sayed If I want to install SharePoint in standalone mode in workgroup, I must run New-SPConfigurationDatabase command before running configuration wizard.

So I installed SharePoint again (I'am using VM), and when I run New-SPConfigurationDatabase I got error:

New-SPConfigurationDatabase cannot connect to database master at SQL server at db name. The DB may not exist, or the current user does not have permission to connect.

I used of built-in administrator account in form domain\account. How do I resolve this?

1 Answer 1

0

EDIT

to re-enable using powershell "after install":

$InstanceName = "SPDistributedCacheService Name=AppFabricCachingService";            
$serviceInstance = Get-SPServiceInstance | ? {($_.service.tostring()) -eq $instanceName -and ($_.server.name) -eq $env:computername}            
$serviceInstance.Provision();      
6
  • how do I access to SQL management studio?
    – GoGo
    Aug 9, 2014 at 5:32
  • I have not SSMS in my system, and I can not success to install it. Also, use the "psconfig.exe -cmd Configdb Create SkipRegisterAsDistributedCacheHost" command caused the distributed cache service will be stopped and not start anyway.
    – GoGo
    Aug 9, 2014 at 12:20
  • Dear @ali SharePoint , Should you ensure that the image is displayed properly ? I can't see it ! Jul 19, 2016 at 10:26
  • images are messed up for some reason. added the links below each one just incase
    – Ali Jafer
    Jul 25, 2016 at 10:28
  • The uploaded images seems to be blank even on link click Jul 25, 2016 at 10:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.