1

I'm having problems deploying a web part in Sharepoint 2007.

I have the following setup: One WFE, one server where I run and develop SSIS and web part solutions that also has sharepoint installed (I think this qualifies as a WFE), and a separate database server. I recently upgraded to x64 and SharePoint has been running fine for a few months. This is the first time I've tried to deploy a custom web part in the new environment. It used to work like a charm but I've had nothing but problems with this attempt.

A few pertinent facts:

  • SharePoint version on both the WFEs: 12.0.0.6421
  • I know the code works because I copied it from a working existing web part (will change it later once I get this figured out)
  • I think this probably has something to do with the fact that my web part development now lives on the d: drive instead of the c: drive but I can't figure out where the problem is occurring.

Here is what is going wrong: After I build the solution (anycpu), copy the dll to the GAC and run WSPbuilder.exe, I attempt to run the setup.exe from SharePoint Solution Installer. (downloaded from www.codeplex.com/sharepointinstaller). On the system check screen, when the installer gets to the final step: "Checking features as specified in Config." It fails with and error: "New Features specified: 1" I can't find anything on google about what this error means.

Here is my setup.exe.config file for the Sharepoint installer:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
    <appSettings>
    <add key="BannerImage" value="Default"/>
    <add key="LogoImage" value="None"/>
    <add key="EULA" value=""/>
    <add key="Require" value="MOSS"/>
    <add key="MinSharePointVersion" value="12.0.0.0"/>
    <add key="MaxSharePointVersion" value=""/>
    <add key="SolutionId" value="172AC3A2-5D5E-44c0-B8CD-572300CC5789"/>
     <!-- FarmFeatureId: Old way to specify a single farm-level feature
        obsoleted by newer FeatureId key -->
     <add key="FarmFeatureId" value="172AC3A2-5D5E-44c0-B8CD-572300CC5789"/>
     <!-- FeatureId: Feature(s) to install/upgrade/repair
        Either a single GUID, or a semicolon delimited GUID list -->
    <add key="FeatureId" value="CB599E4E-6EA8-485E-A3F7-5430118BADB1"/>
     <!-- FeatureScope: Scope of feature(s) specified in FeatureId
      Legal values: Farm, Web Application, Site, Web-->
    <add key="FeatureScope" value="Site"/>
    <add key="SolutionFile" value="ProgWebPart_try3.wsp"/>
    <add key="SolutionTitle" value="Program Web Part Try 3"/>
    <!-- SolutionVersion: Version of solution: this value is stored in the farm property bag -->
    <add key="SolutionVersion" value="1.0.0.0"/>
    <add key="UpgradeDescription" value="Upgrades Program Web Part on all frontend web servers in the SharePoint farm."/>
    <add key="RequireDeploymentToCentralAdminWebApplication" value="true"/>
    <add key="RequireDeploymentToAllContentWebApplications" value="false"/>
    <!-- DefaultDeployToSRP: Whether box for Shared Resource Provider web app is initially checked
        if user is prompted for web applications to target -->
    <add key="DefaultDeployToSRP" value="false"/>
    <add key="DefaultDeployToAdminWebApplications" value="false"/>
    <add key="DefaultDeployToContentWebApplications" value="false"/>
    <!-- PromptForWebApplications: To force user prompt for web application; 
       useful if a dll is included, so SafeControl entries needed, 
       but feature not at webapp level -->
    <add key="PromptForWebApplications" value="false"/>
    </appSettings>
    </configuration>

Here is the feature.xml:

<?xml version="1.0" encoding="utf-8" ?>
<Feature xmlns="http://schemas.microsoft.com/sharepoint/" Id="CB599E4E-6EA8-485e-A3F7-5430118BADB1" Title="Program Page Feature 3" Description="Deploys the Program Page Web Part." Scope="Site">
<ElementManifests>
    <ElementManifest Location="webpartsmanifest.xml" />
</ElementManifests>
</Feature>

Here is the webpartmanifest.xml:

    <?xml version="1.0" encoding="utf-8" ?>
    <Elements xmlns="http://schemas.microsoft.com/sharepoint/">
     <Module Name="WebParts" List="113" Url="_catalogs/wp">
       <File Url="ProgWebPart_try3.ProgWP.webpart" Type="GhostableInLibrary">
         <Property Name="Group" Value="RMI Web Parts" />
       </File>
    </Module>
    </Elements>

Here is the webpart file:

    <?xml version="1.0" encoding="utf-8"?>
    <webParts>
    <webPart xmlns="http://schemas.microsoft.com/WebPart/v3">
    <metaData>
    <type name="ProgWebPart_try3.ProgWP, ProgWebPart_try3, Version=1.0.0.0, Culture=neutral, PublicKeyToken=8778f1e462c36fd7" />
    <importErrorMessage>Cannot import this web part.</importErrorMessage>
    </metaData>
    <data>
    <properties>
    <property name="Title" type="string">Program Web Part try 3</property>
    <property name="Description" type="string">Displays Program Information based on a query string.</property>
    </properties>
    </data>
    </webPart>
    </webParts>

I have the following line in the web.config (The PublicKeyToken for the dll in the GAC matches the one in the web.config):

    <SafeControl Assembly="ProgWebPart_try3, Version=1.0.0.0, Culture=neutral, PublicKeyToken=8778f1e462c36fd7" Namespace="ProgWebPart_try3" TypeName="*" Safe="True" />

Does anyone have any thoughts about how I might resolve this? Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.