2

I am aware of how to connect to a sharepoint online via SPOService, but this does not allow me to run powershell scripts on the file system itself does it? say a document library.

If you open a sharepoint online document library with explorer, document library/library tab/open in explorer, then you can right click and run a ps1 file that will open up a local powershell session with the pwd of the sharepoint file system like this:

PS Microsoft.PowerShell.Core\FileSystem::\contoso.sharepoint.com@SSL\DavWWWRoot\site\shared documents

from this command prompt its just like any other, i now have an interactive session..except i want to open this same type of session as our global tenant, so i can run some scripts that will convert all old office formats to the new xml format, because we will have a lot of E2 users using these sharepoint doc libraries, who will not be able to open or edit old formats.

now i can log into a pc as the domain user that is the global tenant, but i'd rather not if i can somehow get the same result by mounting the doc library file system through some sort of enter-pssession type of connection.

This is all so i can run a bulk xml format converter on sharepoint doc libraries that we are in the process of uploading to various company sites. i can run the script fine here on site, on our file server, but when i run it from the sharepoint online site, i get a lot of confirm prompts, unblock-file prompts, ect... so i feel it has to be a permissions issue because the PS session is running under the local domain user who's logged in. i probably murdered this question, but im not sure how else to put it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.