Before I pose my conundrum, some background:

I have a lab environment with SharePoint 2013 installed and configured. I have also configured SharePoint with FBA, allowing "external users" (to my lab domain) to also sign up and use the SharePoint environment. AD users can successfully log on and use the SharePoint site (sign in with their Windows Credentials) ; External (FBA) users can also sign up successfully and use the SharePoint environment with their external accounts.

A client wants to add MFA to the environment, and I am now in the process of setting this up and testing. As part of this, I have:

  1. Downloaded and installed the Multi-Factor Authentication Server and installed...

  2. Configured the User Portal...

  3. Imported users from AD...

  4. Enabled IIS Authentication, and on the "HTTP" tab (of "IIS Authentication"), I point the base url to my SharePoint site...

After Step 4 above, I test signing in using a test AD account (configured with my Tel. Number) - I get the "MFA call", press # key, and am signed in. Everything works beautifully!

The problem I am experiencing:

Now if I try the same with an FBA user, I am not successful...

In IIS Authentication, and on the "Form-Based" tab, I point the sign in page url of the SharePoint site (where FBA has been configured). However, when signing in, I am taken to the MFA page with the following text:

Login Failed

Please verify the following items:

You entered your usename and password correctly.

You have the correct phone close to you and it has reception.

You entered the correct PIN.

If the problem persists, please contact your company's help desk for assistance.

My assumption was that if the FBA user was not part of the "Users" in the MFA Server, he would be taken to the "Enrollment" page, where he will be enrolled.

What am I doing wrong to enable MFA for a FBA user? Clearly I am misunderstanding, or have mis-configured somewhere :)

Can anyone assist or shed some light on this please?

Thank you.

:) Kind regards,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.