2

I am using SP.ClientContext (JS library) to update some item's fields.

It is working fine on IE but on Chrome I get this error (displayed as alert):

Request Failed, status code 0 text ''

The error is thrown on the line executeQueryAsync

0

Looking at your error I remember coming across this.. This error used to appear intermittently and not always.

This error appears because in SharePoint 2013 the way we have to use JS is changed.

I had solved this problem by disabling MDS: How to turn off MDS on all site collections and sites?

After running above powersheel to disable the MDS (or do it via UI) let me know if the error still persists.

Please note that MDS is a new feature in 2013 which is activated by default. It is not good practice to disable this, but if you wish you can disable it and you will be getting the same pageload performance as SP2010...

The foll. articles describe how to use JS with SharePoint 2013 with MDS enabled:

The correct way to execute JavaScript functions in SharePoint 2013 MDS enabled sites

http://www.greggalipeau.com/2013/09/18/sharepoint-2013-dynamic-javascript-and-minimal-downloads-the-_layouts15start-aspx-conundrum/enter link description here

http://blogs.c5insight.com/Home/entryid/455/account-for-sharepoint-2013-s-minimal-download-strategy-with-your-custom-javascript

http://www.sharepointastic.com/Pages/SharePoint2013MDS.aspx

  • I just checked and it s already false. btw the request is executed fine but I always see that alert – Nk SP Aug 6 '14 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.