5

When creating a document library, and specifying the default document template, the dropdown list of templates out-of-the-box (OOB) includes 97-2003 format files at the top of the list. Users who do not know any better have created document libraries with an old format template as the default. As a result, any new documents end up opening in Compatibility Mode since we have Office 2007 deployed throughout the enterprise.

How do I reorder that template list so that 97-2003 format templates are moved to the bottom of the list?

3

You can set the order of the Content Types used inside the document library settings.

Site Settings > View all site content > Your DocLib > Settings > Document Library Settings > In Content Types section click "Change new button order and default content type"

Here you can hide content types you no longer want to display for the end user and set the order of the content types.

If you dont see the Content Types section instead click Advanced Settings > set "allow mgmt of Content Types" to Yes

hth Anders Rask

3

Take a look at http://office.microsoft.com/en-us/sharepointserver/HA101734541033.aspx?pid=CH101779691033 for the detailed description of how to use Content Types with Document templates. In general, you can associate your own templates with each Content type so that end users don't start with blank files when creating typical documents.

0

Do as Anders suggested and then save this list as a list template and use it instead of original Document Library template when users are creating new libraries.

2
  • Hi Toni :-) That would unghost (oh sorry customize) the lists, wouldnt it? You probably would be better off by provisioning a new list definition. Oh and its Anders, not Andreas ;-) Jan 13 '10 at 9:41
  • Sorry about name typo (fixed). Yup much better, but that seemed a bit complicated to start with so I suggested saving one additional document library list template along with original one. But it would be best to have a custom list definition would be great. Jan 13 '10 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy