1

I have one column vertical web part page, it only has two web parts within the column.

A content editor and a script editor.

The option to Add a new Part is above my current content editor. This is pushing my content down over slightly even when I am outside of the edit page mode. How can I either put my content above the add a new web part or just get rid of it?

  • content editor and script editor web parts will take up some space, are you sure it isn't those causing the problem? – Eric Alexander Aug 5 '14 at 15:54
1

If the problem is empty space between web parts then you could try this

Add a "Content Editor Web Part" to the page. In "Source Editor" type the following css code

<style type="text/css">

.ms-PartSpacingVertical
{
  margin-top: 0px;
}

.ms-PartSpacingHorizontal
{
  width: 0px;
}
</style>

It depends on your css, but maby you need to specify your selector! (or the "bad" way by setting the property to !important)

http://havivi.blogspot.no/2009/08/removehide-empty-space-between-web.html

| improve this answer | |
0

"Add a Web Part" control is always at the top of its corresponding zone when in edit mode. It should be invisible and should not affect your content when not in edit mode. Are you sure there is not something else on the page (empty space) that is causing this?

| improve this answer | |
  • I've only got the script editor which is underneath the CEWP. There isn't any other code on the page either in the editor or in SPD. – Sean Aug 6 '14 at 8:24
0

How much space are we talking? Have you tried editing the web part properties and setting the Chrome Type "nothing" or whatever it's called?

If that's not a possibility then is your script adding white space above the CEWP?

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.