1

I have created a SharePoint 2013 Workflow in Visual Studio 2012. This workflow is activated when a list item is modified.

Once the list item modified, the workflow shows as the started. But on clicking "started" or "workflow name", it throws an error:

The given key was not present in the dictionary.

Stack Trace

[KeyNotFoundException: The given key was not present in the dictionary.] System.Collections.Generic.Dictionary`2.get_Item(TKey key) +14122715 Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.GetRetryMessage(WorkflowInstance instance) +936 Microsoft.SharePoint.WorkflowServices.FabricWorkflowInstanceProvider.GetInstance(Guid instanceId) +463 Microsoft.SharePoint.WorkflowServices.ApplicationPages.WrkStatPage.OnLoad(EventArgs e) +611 System.Web.UI.Control.LoadRecursive() +71 System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3178

Edit: Prior to the above error, an http 401 error (Token contains invalid signature) was thrown on workflow initiation. After following the steps mentioned here, it started throwing the above error.

  • have you checked the uls-logs? – Gwny Aug 5 '14 at 11:00
  • @Gwny Same message as mentioned in stack trace. – Thomas Mathew Aug 5 '14 at 11:07
  • is the list stored in the same site as the workflow? – Gwny Aug 5 '14 at 11:10
  • @Gwny Yes. Both list and workflow are stored in the same SharePoint App web. – Thomas Mathew Aug 5 '14 at 11:33
  • you wrote that you created the workflow in visual studio, are you able to deploy in debug mode? – Gwny Aug 5 '14 at 11:36
1

I have the same error, but it begin appers after re-installing workflow manager on the another server and applying updates. After two days of searching, i've decided to remove proxy and run Register-SPWorkflowService with ScopeName parameter value different from "Sharepoint". See msdn. I recommend to save all your workflows before taking this action.

  • Thanks. I tried that too but didn't work. In the end, i reconfigured Domain Controller and Windows App Fabric and the issue got resolved. – Thomas Mathew Sep 11 '14 at 10:43
1

I face the same issue after installing recommend MS Updates.

It seams there is issue with recent MS update for SharePoint i.e. KB2880998

Hotfix to fix the issue is : KB2880963 (http://support.microsoft.com/kb/2880963)

It has resolved my issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.