0

I added a few custom applications from Office store into our O365/SharePoint Online 2013 and they were smoothly installed and became visible in our Site Content. Only problem is that if I try to click one of them to configure the options all I get is a messed up page with some kind of weird patches of icons/images and text all over the place. If needed, I can try to install the apps again and take a screenshot of the problem/situation later today.

I searched the internet and learned that somehow the app configuration page cannot load CSS styles so that's why the page is messed up. I wonder what is causing that? I have a global alternate CSS file loaded in the Site Collection root site but there aren't any radical changes.

Also I noticed that when I clicked the app to get into the configuration page, it modified the URL by adding an ID of some kind (numbers and letters) after my domain part like this https://mydomain-xxxxxxxxxx.sharepoint.com and normally my URL would be just https://mydomain.sharepoint.com

I appreciate any help on this matter!

  • It should add the id (that is the virtual path to the app-web) – Robert Lindgren Aug 5 '14 at 6:09
  • Ok thanks for clearing that up! I was wondering why it added those numbers and letters in the url. Still any idea why the styles are missing/messed up in the app configuration page and/or how to fix it? :) – Tenttu Aug 5 '14 at 7:13
  • If this is the case for all of your donwloaded apps, and that it is the same if you do remove your global css, you might need to open a support ticket with Microsoft (since this is a hosted environment that you have little control over) – Robert Lindgren Aug 5 '14 at 7:32
  • Ok thank you Robert! I will try to remove the global css and if/when that will not help I will file a support ticket. I'll try to update this question with an answer when I find out what is the cause of this problem and how to fix it. :) – Tenttu Aug 5 '14 at 9:11
1

The problem is now solved and I wanted to write the solution here for anyone else who might run into the same problem. First of all, big thanks to Robert Lindgren for answering with help and information. Secondly, I ended up putting up a support ticket and the problem was that the apps I wanted to configure are english and our Sharepoint native language isn't.

So I needed to go into Site settings -> Language settings and enable english as an optional language. After that the app configuration worked like it should! :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.