I am migrating from WSS 3.0 to SharePoint Server 2010. In WSS in the Web Part Gallery, I could open .xml files for a custom Web Part in the browser, as long as they had the < ?xml... > tag. With 2010, the Name field in the Web Part Gallery links to the .webpart file (which is still xml). But when I click the Name, it prompts me to download it. How do I display the .webpart file in the browser instead?


It turns out the answer is, SharePoint 2010 forces certain file types to be downloaded, even if you associate the file extension (.webpart in this example) with Internet Explorer. I found the answer here:


The author gives detailed instructions for excluding a specific extension, so it is displayed in the browser instead of being downloaded. However, if you are working in a Development environment, and want to just turn off the security setting, follow these steps:

  • Open Central Administration (you must be a Farm Administrator).
  • Under Application Management, click "Manage Web Applications".
  • From the Web Applications Management page, click your Web Application to select it.
  • NOTE: Some extensions are simply blocked. From the ribbon, click "Blocked File Types", remove your extension from the dialog window shown, and click "OK" to save your changes. If your extension is not listed (for example, .xml or .webpart), continue with these instructions.
  • From the ribbon, click "General Settings".
  • From the Web Application General Settings dialog, scroll about halfway down to "Browser File Handling" and select "Permissive".
  • Click "OK" to save your changes.
  • In 2020, I am looking for the same answer for SharePoint 2016, and I find my OWN answer from 2014. Hilarious. Trouble is, it doesn't work for 2016.
    – CigarDoug
    Jun 26 '20 at 1:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.