1

We are using O365/Sharepoint Online 2013 as our intranet solution.

I've been trying to use CSWP to get a rollup of the few most recent discussions on the discussion board to show up on the intranet home page. When I'm setting the query it shows results but after I close (apply + ok) the CSWP tool box and save the page to leave the editing mode the CSWP doesn't show up on the page at all. Is there some feature or another trick that I'm missing?

It's weird since I can add the CSWP on a page, set query and even see that it finds results but after saving the page and leaving the edit mode it doesn't show up like if it was hidden/transparent or something.

I appreciate any help on this matter! :)

5

After a week of troubleshooting with Microsoft Support, I can confirm that as of 9/2014 that SharePoint Online Plan 1 does NOT include Content Search Web Part (CSWP) even though it shows up and lets you add and configure it. Trying to activate Cross Site Publishing feature gives an error message about a feature it depends on, the Search Driven Content feature. If you're on Plan 2, activating the Enterprise feature set will provide this. I can't believe how hard it was to discover this - even with a Microsoft Support tech. Hopefully, confirming it here will help someone else.

1

I've had this problem before and had to enable the Site collection feature: Cross Site Publishing.

  • Thank you for your answer! I tried to enable that feature and all I get is an error that says there is an error in the system and they are trying to fix the problem as we speak so I should try again later. I tried this hours ago for the first time and a few times after that.. still got the error! Let's hope it resolves itself and I can get the feature enabled. :) – Tenttu Aug 5 '14 at 5:17
  • I opened a support ticket with Microsoft and they told me that as we have Sharepoint Online Plan 1 we can't use the CSWP. Still it's strange why it is showing up in the list of web parts I can add if I can't use it! Microsoft logic I think. :) – Tenttu Aug 12 '14 at 5:23
1

I have contacted Microsoft support and showed them this article. They agree that none of the CSWP (including recently changed items) are available on P1 subscriptions. (For the reasons you said above). They are logging it with the bug team, and hopefully the web parts won't show up on P1 plans.

0

I opened a support ticket with Microsoft regarding this issue. They told me that as we are using SPO Plan 1 we can't use CSWP. It says so in the feature comparison too but I didn't think it would be outside our plan's feature range as I could find it in the list of web parts that can be added. Anyways just wanted to share this if someone else encounters the same problem/question. :)

0

The problem still exists. I experienced the same issue last week and opened a support ticket @ Microsoft. Until now I've had no feedback from them.

I discovered that

part of my O365 Business Premium account is Sharepoint on Plan 1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.