0

I have document libraries for each Group.

For example Company1 library for company1 Group and etc.

When they go to site, they see only their library. My needs are that those libraries would be displayed in home page as web parts.

However, when certain Company goes to home page, they see their document library but alos errors for each other Company library:

Web Part Error: Access denied. You do not have permission...

What I want is to hide this error or just to hide libraries in other way. Any solutions?

1

You could possibly create Audiences for your different groups, and then configure the different webparts to only be shown to specific audiences

  • I was trying this method, but didn't find Target Audience option in Edit Web Part Advanced panel, even Audience Targeting was enabled. I googled and find some solutions like editing web.config with space, managing site services and restarting ISS, but none helped me :/ – user3529236 Aug 1 '14 at 17:33
1

You could give each company their own site (under your top site), assuming you have Full Control over your own site. Then you can control the permissions for each site, if needed. You could also give each company its own site collection. If you do, be aware that permissions may need to be managed seperately on each site. (Permissions don't usually don't cross site collections.)

Managing Document Library permissions can get out of hand. As you have seen, dropping one doc. library viewer (of a doc. lib. with unique permissions) on a page can screw up the rest of the page's view due to permissions issues. Sites are cheap, as long as they are managed properly.

Hope that helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.