1

I got a weird issue. We are working on Sharepoint ugpgrade. Hence we have an old SP2010 farm and a new SP2013 farm. We decide not to migrate the User Profile DB. We setup sync connection at both farm to the same AD. The AD's domain name is company.com. Users login with company/user01 to old farm.

After we setup user profile sync on SP2013. It seems fine. All users can login to their site on new farm using company/user01. When they click on "my settings" they can see their account name is company/user01.

However, in the SP2013 CA -> Manage Profile Service: User Profile Service Application page -> Manage user profile. When I search "company" there is no return. It is because all users become "AD/user01", we don't have a domin named "AD"

What can cause the problem? I have tried perform a full sync again but still the same.

  • It's the way it is supposed to be. DomainName/Username. – Christoffer Aug 1 '14 at 7:57
  • Yes it is the problem. It is not showing domainname/username. It is showing AD/username. "AD/user01" is the exact phrase show up in Account name column – Mark L Aug 1 '14 at 8:12
  • Check you User Profile service, on how the accounts get synced, there are 3 different options. try changing it. If that doesnt work, delete the user profile service, ensure that the FIM services on the Component Services in windows has been started, then recreate your UPS – JP Roelofse Aug 1 '14 at 8:22
  • Also make sure that the forest you select when setting the UPS sync is correct – JP Roelofse Aug 1 '14 at 8:37
4

Your domain netbios name (assuming that's where AD comes from) differs from domain FQDN name (company.com), so you need to enable NetBiosDomainNamesEnabled property to get correct domains in user profiles.

"NetBiosDomainNamesEnabled is a property that is set on every UPA. By default, this value is set to false which means that you must set it to true in the scenario where the domain netbios\FQDN names are different. PowerShell can be used to drop the UPA into a variable and set this property to true.

For Example:

  1. Get-SPServiceApplication

    Note: This will output every service application specifically the User Profile Service Application

  2. $var = Get-SPServiceApplication –Identity 00a380ed-2e99-4de3-ae22-dbe8c1b03bab

    Note: the identity is the GUID associated with the User Profile Service Application which was retrieved and copied from running the Get-SPServiceApplication cmdlet

  3. $var.NetBiosDomainNamesEnabled

    Note: if this is true then it’s enabled and you can skip directly to step 7

  4. $var.NetBiosDomainNamesEnabled = "True"

    Note: Here you are setting the property to True

  5. $var.update()

    Note: This is simply running update method against the variable which officially updates the property

  6. $var.NetBiosDomainNamesEnabled

    Note: This confirms the steps were run correctly as the output will display True instead of False

  7. To utilize the domain Netbios name, a new sync connection must be created and used. Yes, this means you cannot use an existing sync connection and expect it to work. Create a new sync connection via the UI:

    Central Admin\Application Management\Manage Service Applications\User Profile Service Application\Configure Synchronization Connections

Source

  • Thanks. I delete the existing connnection, run the powershell to enable NetBiosDomainNamesEnabled, then re-create connnection and re-sync fix the problem! – Mark L Aug 4 '14 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.