I'm receiving the error in the title when trying to access my personal site on the MySite Collection. I can fix this by adding "Full Read" permissions for "Everyone" on the entire web app but I'm not sure if this is secure or a good idea on the web app that hosts the MySite Collection.

With the farm account, I can get onto the site no problem and check permissions for my personal account and see it has no permissions without this setting.

Any ideas?


5 Answers 5


Try creating a permission policy for your web application on Central Administration followingly:

  1. On Central Administration, navigate to Application Management -> Under Web Applications: Manage web applications
  2. Select your My Site -web application by clicking it, and open Permission Policy
  3. Click Add Permission Policy Level
  4. Enter at least the Name for your Permission Policy
  5. Select following Permissions:
  6. Create Subsites - Create subsites such as team sites, Meeting Workspace sites, and Document Workspace sites.
  7. View Pages - View pages in a Web site.
  8. Browse User Information - View information about users of the Web site.
  9. Open - Allows users to open a Web site, list, or folder in order to access items inside that container.
  10. Leave other parts unmarket and click Save
  11. Make sure your My Site -web application is selected and open User Policy
  12. Click Add Users, and on first view leave Zones: (All zones) selected, then click Next >
  13. On Choose Users -part click Browse (the catalogue type of icon). Click All Users and select Everyone activated. Press Add -> and OK
  14. On Choose Permissions, select the Permission Policy you recently created, and finally click Finish

In case you haven't already followed the TechNet's guide Configure My Sites in SharePoint Server 2013, you should from now on :)

  • Thank you for pointing this out on the guide, moe. I appreciate your help. Accepted.
    – tnw
    Commented Aug 1, 2014 at 14:01
  • At point 12, this is where you are supposed to add Active Directory groups and service accounts.
    – Underverse
    Commented Mar 24, 2016 at 1:49

Had the same problem, found this here (worked for me):

If you have credential for account who has rights on site then, by simply hitting below URL, you can have prompt to login prompt.



In my case the problem was that account the site was running on did not have enough permission in Active Directory. Solution: run ApplicationPool under my own account.


If you have this feature enabled: "Limited-access user permission lockdown mode" at site collection level - Deactivate it. - Because, this prevents limited access users from getting Form pages!

Read more: https://www.sharepointdiary.com/2014/01/sorry-this-site-hasnt-been-shared-with-you-sharepoint-2013.html#ixzz66SjMs4nc

Read more: https://www.sharepointdiary.com/2014/01/sorry-this-site-hasnt-been-shared-with-you-sharepoint-2013.html#ixzz66SjMsGhm


check your permissions & try to run by system account that will help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.