2

I am trying to create a custom list that is editable in quick view, only three columns are required (Project Name, Project Start Date, Project Estimated End Date)and I am trying to display it in a custom gantt chart view.

However when an entry is made in quick view it returns with the error:

Sorry, you can't create a new item with Quick Edit because this view is missing one or more required columns. To create a new item, please click "New Item" or add required columns to this view.

It seems to require the "Title" column, even though this is set to optional in the default content type. In fact in the new item form it allows an entry to be made without the title field being filled.

Is it possible to remove this requirement or does this rabbit hole go too deep?

3 Answers 3

1

If you want, you can hide the Title column in editing item in Content Type in List Setting, and it won't appear in NewForm also EditForm.

But when you do that, the first column is not display as a link and show menu edit item will be gone too.

1

After review, it appears that the title field is a required element and cannot be removed. However it can be renamed.

0

To get rid of this error in Sharepoint 2016

  1. First make title field non required
  2. Go to list setting list setting and make Allow management of content types? "Yes"
  3. Click on OK in the bottom of screen
  4. After that extra section will appear enter image description here
  5. Click on item then title and choose optional or hidden then okay
  6. hide title from edit view if you won't show it in your form or quick edit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.