3

I am responsible for a SharePoint 2013 farm that uses Standard CALs. As a result, we don't have a Visio service application provisioned.

I have a Visio document in a document library, and when I click the link I'd like it to simply open it in the Visio client application. Instead, it tries to open in the browser and gives the following error message:

Sorry, we couldn't open your file using this feature. Visio Web Access is not available on this site.

I thought there might be a binding for it in Office Web Apps, but running Get-SPWOPIBinding I don't see anything for .vsd or .vsdx extensions.

How do I get it to skip trying to open in the browser and go directly to the client application?

  • Did you find a solution to this? I have the same problem. – Skaft Mar 14 '16 at 9:46
2

In the document library settings, there is an override available. Simply click on the Advanced Settings link and set the Opening Documents in the Browser section to Open in the client application.

  • But I only want it to do that for Visio documents. – jason.venema Jul 30 '14 at 18:27
  • is it an on prem farm? If so you could try to add the vsd mime type on the WFEs as application/octet-stream to force a download – Eric Alexander Jul 30 '14 at 18:36
  • It is an on prem farm. I tried your suggestion on both WFEs, did an iisreset, but still get the error message. – jason.venema Jul 30 '14 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.