One of my coworkers has this problem for some of the files stored in a document library. If he clicks on the link, from the document library, the dialog has these two options: "Read-only" and "Edit" - once excel opens the file there is no "Check out" button at the top, nor is there an option to check it back in on the backstage view. For other files he gets the normal options: "Read-only" and "Check out and edit". This only happens when clicking on the link; if he clicks the arrow for the drop-down menu and selects "Check out" from Sharepoint before clicking the link he can then edit any document and can check it back in after.

Why does that happen for some of the files? I looked for similar problems (looks like they're quite common, despite the lack of solutions) and the only answer was to check whether he's using Internet Explorer 64-bit.

He is using Office 2010, Sharepoint 2010 and Internet Explorer 32 bit. All the files are .xlsx files.

  • Did you find anything about this yet?
    – Vinz
    Commented Aug 5, 2015 at 12:50
  • 1
    Sorry for the delay. No, I haven't - as a matter of fact, I work somewhere else now and don't deal with SharePoint anymore (thank God). Are you having the same problem? Commented Aug 26, 2015 at 3:47
  • Yes indeed. It came after I upgraded to Windows 10. My excel just wont let me check out my document anymore. I download it now fully and work on a local copy which I overwrite from time to time... Man I wish I could work with something else as well...
    – Vinz
    Commented Sep 2, 2015 at 14:49

2 Answers 2


I cannot say exactly what is happening but I've had similar problems, resolved by one or more of the following:

  • Repair Office 2010 on the client machine and restart
  • Upgrade to IE10 or above
  • Remove cached files from the upload center

Here are some other things to check, hope it helps.

  1. Does the user have contribute access to the document in SharePoint?
  2. Does the library require check out? (library settings > version settings > require check out (yes/no))
  3. Under Library settings > advanced settings is the library configured to Open the documents in the browser or client application?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.