0

When trying to debug a workflow created in SharePoint 2013 App using Visual Studio 2012 version, i am getting the error "workflow debugging prerequisites failed to complete". I tried to publish the app first and then debug, but still got the same error.

  • Having same issue but could not resolved... Environment : Server 1 SP 2013, SQL Server 2012 SP1 Visual Studio 2012 Workflow Client, Workflow Management Tools CU2 Server 2 Workflow Manager updated with CU2 Any help on this would be highly appreciated. thanks – user32228 Aug 6 '14 at 15:37
0

Is your Visual Studio fully updated?
The following link is for 2013 version but it seems to have encountered exactly the same error:
http://social.msdn.microsoft.com/Forums/sharepoint/en-US/733af28d-7a01-487b-822b-36bfc095fac9/workflow-debugging-prerequisites-failed-to-complete-vs2013-autohosted-app?forum=sharepointdevelopment

Have a look at the following link as well: http://blogs.msdn.com/b/officeapps/archive/2013/10/30/debugging-sharepoint-2013-workflows-using-visual-studio-2013.aspx

You must enable Service Bus debugging if you want to debug workflows on Office 365. If your project targets SharePoint installed on your local network, you do not need to enable Service Bus debugging. Instead, you need to open incoming connections to TCP port 12292. If you use Windows Firewall with Advanced Security, you can simply enable the rule “Workflow Manager Tools 1.0 for Visual Studio 2012 - Test Service Host”. If you try to debug against a SharePoint host on the local network without opening the port, Visual Studio will prompt you to enable the rule.

|improve this answer|||||
0

The problem was with workflow manager configuration. Reconfiguring it again resolved the issue. Also, since the SharePoint version was updated from RTM to March 2013 Public Update, i had to register the workflow service again. Reference http://www.andrewconnell.com/blog/Updates-For-SP2013-Workflow

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.