2

SharePoint 2013 farm with 3 web front end 2 web app and 2 workflow server.we have scheduler running sharepoint warm up scripts at 2am in the morning to beat the morning rush hour traffic. Couple of sites on our site collection fail to warm up with the scripts( which i yet have to figure it out why). But not always but oftenly i get another error in my event viewer related to MetadataWebService.svc stated below right after the failed Sharepoint Warm Up:

A failure was reported when trying to invoke a service application: EndpointFailure

Process Name: OWSTIMER

Process ID: 3428

AppDomain Name: DefaultDomain

AppDomain ID: 1

Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:b1d71c1a38f943029c8fa60d337e50d3#authority=urn:uuid:47cb52ff6db746d9b6030e6c3bf1b4fb&authority=https://nameofserver:32844/Topology/topology.svc

Active Endpoints: 4

Failed Endpoints:1

Affected Endpoint: 

    http://nameofserver:32843/b1d71c1a38f943029c8fa60d337e50d3/MetadataWebService.svc

Now the weird things : After it fails the first time it completes sucessfully 2nd and third time. and it happens randomly after that until couple of hours and it dissappears when there are high volume of users at the day time. Then in the evening when Symantec updates its virus definition it seems to fail again.

Then next day its all random again.

I checked My services running in Server under central admin. Its status is set to started and behaving normal.enter image description here

I also checked my metadataService Apps under Application management--> manage service applications

enter image description here

In SharePoint Logs i see this:

WcfSendRequest: RemoteAddress: 'http://nameofserver:32843/78c53cb88d7f4d52b067b294144e333a/MetadataWebService.svc' Channel: 'Microsoft.SharePoint.Taxonomy.IMetadataWebServiceApplication' Action: 'http://schemas.microsoft.com/sharepoint/taxonomy/soap/IDataAccessReadOnly/GetChangedTermSets' MessageId: 'urn:uuid:3f41050d-49c4-4254-b05a-afa0b8266837'

Exception returned from back end service. System.ServiceModel.Security.MessageSecurityException: An unsecured or incorrectly secured fault was received from the other party. See the inner FaultException for the fault code and detail. ---> System.ServiceModel.FaultException: ID3242: The security token could not be authenticated or authorized -- End of inner exception stack trace --- Server stack trace:
at System.ServiceModel.Channels.SecurityChannelFactory1.SecurityRequestChannel.ProcessReply(Message reply, SecurityProtocolCorrelationState correlationState, TimeSpan timeout)
at System.ServiceModel.Channels.SecurityChannelFactory
1.SecurityRequestChannel.Request(Message message, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message) Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Microsoft.SharePoint.Taxonomy.Internal.IDataAccessReadOnly.GetChangedTermSets(DateTime sinceTime, String propertyName, String propertyValue)
at Microsoft.SharePoint.Taxonomy.Internal.TaxonomyProxyAccess.<>c__DisplayClass43.b__42(IMetadataWebServiceApplication serviceApplication)
at Microsoft.SharePoint.Taxonomy.MetadataWebServiceApplicationProxy.<>c__DisplayClass2f.b__2d()

  • as far as you have one active end point you will be fine. I am wondering why you have 5 end point total for MMS. I would stop the MMS services on the server where it is failing. simply stop the services from manage services on server> select server and stop it their. MMS on all 5 server is not recommended way. – Waqas Sarwar MVP Jul 23 '14 at 21:03
  • I only have MMS running on 2 app servers. – allegro octopus Jul 23 '14 at 21:11
  • failing end point is on one of two server – Waqas Sarwar MVP Jul 23 '14 at 21:16
  • to fix bad endpoint. you need a down time for MMS service app. what you should do...stop the MMS services from Central admin on all runing server....Now go to the IIS on all server where it is running and make sure no app pool exit for MMS...if any related to MMS delete it....after that restart the services on server will fix this. – Waqas Sarwar MVP Jul 24 '14 at 2:08
  • 2
    The above solution is what MSFT recommend in the same issue with Search EndPoint failure and we never get an answer why it is failing....key is, if one endpoint alive all the time then no issue with services application's functionality....i would recommend, open a support case with MSFT on this. – Waqas Sarwar MVP Jul 24 '14 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.