I created custom display template for displaying list items, I'm able to get values like Path,Title ..etc, but when when i try to access list column managed property (ex : xxxOWSTEXT) am getting null in it,

I'm getting values if I call ctx.CurrentItem.ListID,ctx.CurrentItem.ListItemID but if I call ctx.CurrentItem.xxxOWSTEXT I'm getting null value.

I declared managed property in 'xxxOWSTEXT':'xxxOWSTEXT' correctly, please let me know how to resolve this.

5 Answers 5


I solved this by ticking "optimize for frequent use" in the Result Type. Here is the link.

You can also test with the "Ultimate diagnostic display template" found here.

  • This saved me . the custom site column (Managed Property) returns the desired values after enabling "Optimize for frequent use" from Result Type Settings
    – Esaki
    Sep 1, 2021 at 8:52


Important note: Only site columns that contain values automatically become managed properties when they're crawled. Regular columns do not!

Go to > http:// XYZ /_layouts/15/listcrawledproperties.aspx?level=sitecol Find that xxx column crawled property, create managed property and map that crawled property to that managed property.

In Item on line 8 (mso:ManagedPropertyMapping msdt:dt="string") add that managed mapping 'xxxOWSTEXT '{xxxOWSTEXT }:'xxxOWSTEXT ',

Create variable >

var xxxOWSTEXT = $getItemValue(ctx, "xxxOWSTEXT"); 

And call variable with this _#= xxxOWSTEXT =#_

  • Hi , Thanks for replying, I tried with same as you explain but still issue exists, may be I need to run full crawl..
    – Nag1987
    Jul 23, 2014 at 9:41
  • Full crawl is needed for crawled property to appear and at least one item must have value.
    – Marko Tica
    Jul 23, 2014 at 9:58
  • Hi User31714, full crawl is running and so far no results. FYI. the site is migrated (back up and restore) from UAT to production where in UAT Managed Properties are resulted good.
    – Nag1987
    Jul 23, 2014 at 10:17
  • Then wait for full crawl to complete
    – Marko Tica
    Jul 23, 2014 at 11:13
  • Hi User31714 I verified after full crawl still results are null for my custom properties. Is there any way to resolve this!.
    – Nag1987
    Jul 25, 2014 at 6:23

Please check if your Managed meta data column is site column. Because if it is not then it will gives null.


Try to reset the index and start a full crawl.


I added in a field for a people search result and I was getting null values like OP. My resolution was due to the managed property. This needs to be set at the Central Admin level on the search settings page under Search Schema in order to be crawled. I had also added the managed property on the Site Collection level but this caused a conflict for me. I deleted at the Site Collection level and it got the managed property from Central Admin and the value showed up no problem.

As stated by others, a full crawl is required after adding a new Managed Property.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.