Hi I want to install sharepoint 2010 foundation on my Windows 7 machine for testing and development purposes. For that, I followed the exact steps described in MSDN under the title “ Setting Up the Development Environment for SharePoint 2010 on Windows Vista, Windows 7, and Windows Server 2008”

After that , I run SharePoint products configurations wizard to deploy the remaining operations. The wizard run smoothly without any problems and it gives me the message “ Configuration Successful” However, when it redirects me to the home page from my SharePoint I got the HTTP 500 error ( the page can’t be displayed). I also tried SharePoint Central Administration but still I get the same error message.

Any help would be appreciated

I found this message inside Windows Event Viewer

An exception occurred when trying to issue security token: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (application/soap+msbin1). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: ' IIS 7.5 Detailed Error - 500.19 - Internal Server Error

I didn't find any log file inside my SharePoint root folder and I changed the attributes in my web.config as stated below. In addition, I changed the default port for SharePoint from 32212 just to try if it's gonna work on another port but the problem still occurs

  • Try an IISRESET from a command prompt. It's the SharePoint equivalent of "have you turned it off and back on again?" :)
    – James Love
    Apr 10, 2011 at 12:31
  • the Internet Service stopped & restated successfully which mean no problems at all with my IIS
    – Besho 87
    Apr 10, 2011 at 12:38
  • Always worth a shot though. Also check in IIS to make sure all the App Pools are up and running.
    – James Love
    Apr 10, 2011 at 13:01

2 Answers 2


Three things you need to do when you get HTTP 500 errors:

  1. Check the event viewer for any kind of errors related to SharePoint, IIS etc
  2. Check the SharePoint trace/ULS logs for errors, exceptions etc (they are located in {SharePoint Root}\LOGS by default
  3. Edit the web.config of the web application you are getting the error on and set CallStack="true", CustomErrors="Off" and debug="true"

When you have more information, please either update your post with more error details or how you solved the problem.

  • Well, I found this log message inside Windows Event Viewer
    – Besho 87
    Apr 10, 2011 at 14:24

I remember having a similar problem, try installing the following module: rewrite_2.0_rtw_x64.msi (http://www.microsoft.com/downloads/en/details.aspx?FamilyID=1B8C7BD8-8824-4408-B8FC-49DC7F951A00&amp%3Bdisplaylang=en)

(I had blogged about a similiar issue earlier at http://vasya10.wordpress.com/2011/01/26/sp-2007-to-sp-2010-migration-issue-1/)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.