0

I had an existing farm that was run on HTTP and we upgraded the farm to be all SSL enabled. I had updated the URLs for all web applications to be https and used URL rewrite rules on all IIS servers to redirect HTTP requests to HTTPS.

This morning I tried changing the AAM for the My Sites collection to be https only. When I did this, I got 401 unauthorized errors when visiting the One Drive or viewing the Newsfeed for a my site. If I add back in the http binding, it works.

Is there any way I can remove the requirement of having an AAM listed for an HTTP site? Do I have to update the Work Management service somehow to only go to HTTPS?

  • did you updated the mySite host location, from user profile? – Waqas Sarwar MVP Jul 21 '14 at 15:18
  • @WaqasSarwarMCSE Bingo! That was it. – jkandiko Jul 21 '14 at 19:08
  • i just added it as an answer, so please mark it so that other gets benefit from it. – Waqas Sarwar MVP Jul 21 '14 at 19:18
1

For MySite. You have to make changes two places.

  1. Update the MySite Host in the User Profile Services Settings.
  2. Update AAM for the MYSite.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.