4

I am hoping this question has a really simple answer to it.

I am currently in SharePoint Designer editing an .aspx page.

I added an empty data view, then added a data source for one of my document libraries. I can then select from the ribbon the columns I want add from this library, it then puts all the code into designer. Then when I click save to preview it in the browser, the code in designer changes from the one initially put in. The option to add and remove columns for that library is then gone and I can no longer amend the information from that instances.

Why does the code change when you save it and why can I not amend that data view once I have saved it?

I am using SP2013

Thanks

  • have you tried using Insert -> Data View -> your list name instead of starting from a blank data view and adding in a source? I think if you start from scratch you're probably missing a bunch of XML that enables basic operations like adding columns and stuff – John-M Jul 18 '14 at 13:00
  • I can add columns in when I add an empty data view then a data source, the option is there initially on the ribbon for to add/remove columns etc. Its once I have saved it that the initially inserted code changes to something a lot more simplified and I can no longer use the data view edit option on the ribbon. It just doesnt show up – Sean Jul 18 '14 at 13:16
0

I really hate SPD 2013, and what happened to you is one of the many reasons. Go to the code and click anywhere inside the tag.

<WebPartPages:DataFormWebPart>

and the Add/Remove Columns should be available again, otherwise will gray-out. I hope this helps.

0

This is a known issue in SharePoint Designer 2013.

With the page open and active in designer, press the save button.

Right-click on the tag of the item you are working with (WebPartPages:DataFormWebPart) and go to tag properties.

without changing anything, just press ok. This should show the Data View Tools' tabs in the ribbon.

now you should be able to add/remove columns, add parameters, filter, sort, etc. Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.