1

On our development SP2013 farm, I have enabled Blobcache according to MSDN.

I simply changed the line to enabled=true and create a folder c:\Blobcache.

After some days, I found there is nothing in c:\Blobcache and when I check back web.config, the line of BlobCache have been changed back to default. The Enabled attirube become "False" as default.

What kind of action will cause the change? Do I missed some setup to make attribute fixed? Thanks for advice.

2

Did you uninstall a solution in the meanwhile?

There is some kind of web.config versioning going on in SharePoint when you install and uninstall a new SharePoint solution package.

  • Yes! I was debug some solution using visual studio 2013. So Visual Studio disable the Blobcache for me? If so it should be a bug. – Mark L Jul 21 '14 at 2:25
  • Not really a bug. If you uninstall a rollback logic will take place. Since you edited the current web.config file directly, the rollback will (incorrectly) conclude that the change in blobcache was a change done together with the installation of the latest solution. When uninstalling the latest solution the change in the blobcache setting will also be rolled back to the previous state. – Wout Jul 22 '14 at 6:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.