2

Our environment consists of 3 SharePoint 2013 farms: Production, Test and DR. The Production and DR farms are exact replicas from a physical architecture standpoint, and we are using SQL async mirroring for failover.

We have a single Office Web Apps 2013 farm consisting of 2 servers. The production SharePoint farm is connected to it, and works flawlessly. Yesterday, we performed a test failover to DR and noticed that the only thing not working was Office documents in the browser. We consistently get the message "Sorry, there was a problem and we can't open this document. If this happens again, try opening the document in Microsoft Word."

We have verified that the "Allow List" for the OWA farm is empty, so it should allow requests from any server (and remember, it works in production). We have tried removing the WOPI bindings using:

Remove-SPWOPIBinding -All:$true
New-SPWOPIBinding -ServerName <wac_server_name>

We have verified that the WOPI zone is set to external-https, as our WAC farm uses SSL. None of these attempts have worked.

The one thing I have noticed that seems odd is that the SSL certificate on the WAC farm does not have a SAN field. I thought this was a requirement (http://technet.microsoft.com/en-us/library/jj219435(v=office.15).aspx#security), but it seems to be working in production, so what gives?

  • how did you fixed this ? I have the same issue :( – user42924 Jun 3 '15 at 6:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.