5

I have a problem finding information regarding what the file size limit is when uploading files through the "Upload Multiple Documents" functionality in a library. Does any one know the size limit? (I am not asking about the number of files to upload only size of one single file)

I have configured my farm to handle files up to 1gb and there is no problem uploading that as long as i do not use this functionality. The files i am testing with is 500MB big. And i get a Failed status as soon as i push the OK button to start the upload.

4

files over 100 in size is the max ammount you can do, any more files and it will fail.

You need to use windows explorer view on the document library to upload in big bulk ammounts!

similar answer here:

Cannot upload 600 multiple documents in document library

EDIT

just to make it clear, 100 relates to the ammount of files you want to bulk upload. The max ammount of files you can bulk upload is 100 file. You cant change it as its hard set and not soft set. You need to use explorer view to migrate bulk files above 100!

as for the total file size, its all on central admin:

central admin -> application managment -> manage web applications -> select a web application you want to change -> within the tab above select general settings -> within the popup scroll down till you get to 'Maximum Upload Size'.

the default is 50MB, the max if i remember right is 2GB. Be it for one file or 500 files, it calculates it all as a combined ammount.

example:

1) i set size limmit to 2GB, i have 90 files and totaling 1.5GB

that would upload fine as its under 100 files and the total combined size of 90 files is under 2GB.

2) i set size limmit to 2GB, i have 105 files and totaling 1.5GB

this will fail as it surpasses 100 file limit. The file size is still fine tho as its 1.5GB and max is 2GB. To get this working I would break the file ammount to two bulk uploads or use explorer view on the document library.

in your case your asking about uploading one file at 500mb within multiple upload form and you have set a max of 1GB upload limit.

as its a big single file have you set the web application web.config properly?

find and set it to this:

<httpRuntime executionTimeout="5600" maxRequestLength="901200" />

the above code is setting the upload limit for iis to 901.2 MB, giving the timeout a bit longer to execute due to the large upload aswell! set above accordingly (close to 500 mb mark)

http://msdn.microsoft.com/en-gb/library/e1f13641(v=vs.85).aspx

  • are you talking about the number of files or the file size? – Robban1980 Jul 16 '14 at 11:34
  • im talking about the number of files, its hard set to 100 number of files.. the file size is set to 50mb default but can go upto 2GB – Ali Jafer Jul 16 '14 at 11:41
  • So back to the question, which was about file size for the Upload Multiple Documents. Where is the Upload Multiple Documents configured to allow larger file sizes? – Robban1980 Jul 16 '14 at 12:27
  • just update my answer, the issue could be related to you web.config settings – Ali Jafer Jul 16 '14 at 12:56
0

I have found the answer to my question and thought I should post the proper solution.

The multi-file upload dialogue requires that you change your IIS settings manually in combination with changing your normal SharePoint settings to upload larger files. The default max upload size is 27mb.

After you have done your normal settings of changing the max upload size and time-out settings you will need to open a command prompt as administrator and enter the following command on the SharePoint servers.

%windir%\System32\inetsrv\appcmd set config /section:requestfiltering /requestlimits.maxallowedcontentlength:<size_in_bytes>

Where you replace the with the max upload size you want to allow. so if I want to allow 500 MB file to be uploaded I enter (500x1024x1024=524288000)

 %windir%\System32\inetsrv\appcmd set config /section:requestfiltering /requestlimits.maxallowedcontentlength:524288000

Then depending on your network connection to the SharePoint server you might also need to manually update the connection time-out setting of the web application your SharePoint site is running on.

  1. Open IIS Manager and expand sites and select your web site that you want ot be able to upload larger files to.
  2. Open Advanced settings on the site
  3. Under Behaviour expand Connection Limits
  4. in the Connection Time-out field enter the new value you want to use in Seconds.
  5. Click OK to save.

If you want to use scripting for this option you can enter the following

%windir%\System32\inetsrv\appcmd set config -section:system.applicationHost/sites "/[name='<web site name>'].limits.connectionTimeout:00:10:00" /commit:apphost

replacing the value of with the sate name of the site you want to upgrade

So if I want to change the connection time-out to 10 minutes I would write

%windir%\System32\inetsrv\appcmd set config -section:system.applicationHost/sites "/[name='SharePoint - 80'].limits.connectionTimeout:00:10:00" /commit:apphost

The configuration file that is being updated with these commands can be found here on your SharePoint server

%WinDir%\System32\Inetsrv\Config\applicationHost.config

Hope this helps someone in the same situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.