2

I created a protected, macro enabled, .xlsm workbook on excel 2010 that is meant to be edited by many people. I uploaded it on my company's SharePoint site (Not sure if it is 2010 or 2013, I can't find anything that specifies) so that everyone can access it and check it out and make edits. Some people still have office 2010 and some have been upgraded to 2013 but the people with 2013 have not been able to open the workbook and be able to edit. Every time the 2013 people try to open the file (even when I right click and choose "Open in Microsoft Excel"), it tries to open in the browser anyway and fails because the file is protected and contains vba. It works fine for the people who still have office 2010.

I have already changed the library settings to only open in client application but it still doesn't work for excel 2013 people

I do not think I will be able to get administrative access (I am an owner of a site tho) so I don't think I can get to the Central Administration site (to my knowledge, anyway). Are there any other settings I need to change? It is very frustrating that it works and opens in Excel 2010 but refuses to in 2013. I have done some extensive research online but have not found anything that works for 2010 and not 2013.

If there are any work-arounds or anything I am forgetting to do I would greatly appreciate it.

Edit: For the record, I am also using 32 bit IE because I have already picked up that it doesn't work for ANYONE on chrome or 64 bit IE.

  • Have you tried opening the workbook from Excel? – wjervis Jul 14 '14 at 18:37
  • I don't really understand what you mean "from excel." I want it to open in excel opposed to the browser when it is clicked on... – user3757447 Jul 14 '14 at 18:47
  • Open from Excel as opposed to opening from the browser. Open Excel. File > Open > Other Web Locations > Browse. Enter in url to the library the workbox resides in, and open. – wjervis Jul 14 '14 at 18:58
  • Oh I see. Let me find one of the Excel 2013 computers and I will try it. – user3757447 Jul 14 '14 at 19:10
  • @wjervis Yes that actually does work. WHen I go to File -> Open -> SharePoint it can find the document, and when I open it it prompts the user to check in. Thank you. – user3757447 Jul 14 '14 at 19:29
0

This does not solve why the SharePoint link does not open the client application, but allows the workbook to be opened, nonetheless.

Open the workbook from Excel, as opposed to opening from the browser by doing the following:

Open Excel > File > Open > SharePoint (Or Other Web Locations) > Browse.
Enter the Url to the library, and open the workbook.

1

Verify the browser version you are using matches the bit version of Excel.

For example,

  • If you have the 32 bit version of Excel installed, use the 32 bit version of Internet Explorer.

  • If you have 64 bit excel, use the 64 bit Internet Explorer browser. 64 bit browser can't open the 32 bit application.

It sounds like your Office 2010 users had 32 bit office installed, but the pc's you updated are running 64 bit. Test it out and see.

If SharePoint 365 can't open the client application, it's going to try the browser version, but the browser version can't open the protected file.

0

Rather than click on the name of the file, click on the ellipsis menu (...) next to the name and then select Edit. This should open the file directly in the client app. When you click on the name, you are rely on SharePoint to correctly interpret the config settings which don't always seem to do as you expect when you have older versions of Office (or documents created with said versions) which don't use claims based authentication. enter image description here

  • Is clicking on the dots a method that is taught by Microsoft? My boss thinks it is a work-around and not a solution. – user40893 Mar 26 '15 at 17:48
  • @Tom - The ellipsis menu is not a workaround, it is a functional part of Sharepoint. – Roger Mellie Mar 27 '15 at 15:31
  • I believe the root cause of the issue is that you are trying to open a document that uses classic mode authentication (Office 2010) on a system that uses claims based authentication (Sharepoint 2013). The solution is to make sure you save the document as Excel 2013, but this obviously leads to issues in the real world where you have mixed Office environments and the 2010 users may then not be able to open the file. – Roger Mellie Mar 27 '15 at 15:37
0

This has been happening to one computer in our company, and no others. Our solution is this: regedit look at SharePoint.OpenDocument.5 (search for it or locate it under HKEY_CLASSES_ROOT) on a computer where it is working correctly you will notice if you rename this key, Sharepoint will only open in ExcelOnline (or WordOnline etc), but if you restore this key to the correct name, it will open in Excel native.

In the issue computer's case, this key was named properly but there was an extra key under SharePoint.OpenDocuments (no number) called CLSID (this folder / key exists in the other Sharepoint.OpenDocuments.x but it shouldn't be under Sharepoint.OpenDocuments). I exported it before deleting it just in case. After this key was removed this resolved the issue!

All in all, compare these keys (SharePoint.OpenDocuments - SharePoint.OpenDocuments.5) from a machine where it is working properly to the issue computer and adjust accordingly.

I hope this helps someone else out there that went through this because it was very frustrating.

Good luck out there,

0

I have this issue in Chrome and it looks that NPAPI plugin which provided this functionality was removed/disabled by Google. My solution was to use "IE Tab" add-on, it opens a site with IE inside Chrome. More details about the issue: http://blogs.technet.com/b/office_integration__sharepoint/archive/2015/04/24/unable-to-open-sharepoint-documents-in-rich-client-from-chrome.aspx

IE Tab: https://chrome.google.com/webstore/detail/ie-tab/hehijbfgiekmjfkfjpbkbammjbdenadd?hl=en

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.