1

Has anyone come across a situation (in SP2013) where accessing

http://myserver.domain.com/

Gives "Sorry this site hasn't been shared with you", yet any other address, including the address of the welcome page that this is supposed to redirect to, works fine?

So, yes,

http://myserver.domain.com:1234/ - another web application, works fine http://myserver.domain.com/sites/Site1 - another site collection on the initial web application, works fine http://myserver.domain.com/pages/home.aspx - the home/welcome page for the initial site, works fine http://myserver.domain.com/_layouts/settings.aspx - the settings page for the initial site, works fine http://myserver.domain.com/SubSite/ - a sub-site of the initial root site, works fine

The ONLY URL that causes an issue is http://myserver.domain.com/. I'm authenticating as the site administrator, but it doesn't matter who I do it as, including the farm account.

There's nothing odd in the ULS log, I've even tried debugging it, but all I know is that for that site it's called SPUtility.HandleAccessDenied from SPFederationAuthenticationModule.OnEndRequest whereas for every other URL it doesn't call that.

  • what are the AAM settings of the Web App – Waqas Sarwar MVP Jul 14 '14 at 14:17
  • All web apps have the same default settings, no additional AAMs configured. – Dylan Nicholson Jul 14 '14 at 20:54
  • FWIW I just installed SP1 and did a full psconfig etc. No change. – Dylan Nicholson Jul 15 '14 at 1:41
  • 1
    Did you ever figure this out I have same issue? – user38852 Jan 21 '15 at 1:38
  • Nope...still a mystery, but not using that installation much anymore. – Dylan Nicholson Jan 21 '15 at 5:56
1

In my opinion it is not a problem with the AAMs as you can access http://myserver.domain.com/pages/home.aspx and other pages of this site. It sounds to me as if the problem would be located on your root site.

Just as a first step: Did you check if masterpage, style sheets, script files etc. are checked in and published? (although I think that at least administrators should be able to see the page even if there are some files not checked in or published - but it's worth a try).

Another approach to solve this problem (a more promising one in my opinion): Open your root site in SharePoint Designer. At first, create a copy of your default.aspx as backup. Edit your default.aspx in advanced mode. Remove the code of all webparts from the ContentPlaceHolder "PlaceHolderMain", save the file and try, if you can access the site now in your browser. If so, add your Webparts step by step back to the page. So you should be able to identify the webpart which is causing the problem.

  • 1
    I haven't done any customisation at all on the start page. There is no default.aspx (or any of the other pages that IIS uses as the default). I don't have SharePoint designer installed (though I do have InfoPath). – Dylan Nicholson Jul 21 '14 at 5:34
0

Did you try to access http://myserver.domain.com/pages/

Better check claim authentication setting and Claims Authentication Types (NTLM) try to Add the admin user to the site in format (i:0#.w|domain\user).

  • Yes that works too. There's no difference in the claims authentication settings etc. between web applications. – Dylan Nicholson Jul 14 '14 at 20:23

protected by Community Jan 21 '15 at 3:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.