6

I am using SharePoint 2013. When I log in in my site it asks me to do so 3 times. I think the reason behind it is because I am using two apps, so it once asks to log in into the page and later asks for each app. When I log in just once it keeps me logged in but in the space where the apps were supposed to be, is only one error message about the certificate. Moreover it asks me to log in whenever I have a document and try to open it. Is there any way I can get rid of these problems? It would be good if word and excel automatically import the credentials from the SharePoint account which is logged on.

1

Add the SharePoint site to the intranet zone or trusted sites zone (browser settings).

If that does not help make sure that all the loaded content including images, css files, etc... are all loaded from the same domain.

0

In what internet zone is your SharePoint site accessed? The normal zone for your SharePoint is the Local Intranet zone.

You can add your SharePoint site to this zone using manual Internet Explorer settings or using a Policy.

Try verifying if your SharePoint site is added to the Local Intranet: Internet Options > Security > Local Intranet > Sites > Advanced.

  • 1
    It is located in the default internet zone which I suppose is local intranet zone – el94 Jul 10 '14 at 9:48
  • I don't think "Default Internet Zone" is the same as the "Local Intranet Zone". Try verifying if your SharePoint site is added to the Local Intranet: Internet Options > Security > Local Intranet > Sites > Advanced. – TempaC Jul 10 '14 at 9:53
  • Also, are you using SharePoint Online? Or are you using SharePoint located in a farm? – TempaC Jul 10 '14 at 10:05
  • 1
    It is located in a farm in our servers inside the local intranet zone – el94 Jul 10 '14 at 10:09
0

i'm having the same issue but in a different context I would start with editing the registry key in the sharepoint web front end server basically you would need to disable LoopBack or alternatively add the host name to backhostnames registry key see below

http://www.jeremytaylor.net/2010/05/24/sharepoint-disable-loopback-check-disableloopbackcheck-dword-in-registry/

0

I had this issue and tried almost everything out there on the internet from ensuring all URLs were relative and no Absolute URLs were being used. The theory behind that was that an absolute URL from another zone may require you signin again to get a session pertinent to that zone. Check all the articles for loopback, and everything was looking ok at SharePoint end.

Resources that I followed are mentioned below.

http://www.jeremytaylor.net/2010/05/24/sharepoint-disable-loopback-check-disableloopbackcheck-dword-in-registry/

https://social.technet.microsoft.com/Forums/en-US/e371964b-a72d-44d9-a976-18a2074c438a/extended-webapplication-repeatedly-prompts-for-credentials?forum=sharepointadminprevious

https://docs.microsoft.com/en-us/sharepoint/administration/configure-object-cache-user-accounts

My environment was hosted on AWS and after all of the research, in my case, it was a configuration on AWS that was incorrect causing the cookies to be replaced halfway through, getting the browser confused about the login session and asking to login again and again.

I hope this helps someone in despair.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.