1

This is for SharePoint 2013.

I'm new in this domain.

I have to realise an intranet with SharePoint 2013. I want to display a property in people search results.

I followed this post, it works well, I display the "location".

But the problem is that it displays the value that is in "Central Administration --> Manage User Profiles".

And I want to display the value that is in "Edit Profile" when you click on the name of someone (when you use the search for poeple e.g) and you go in his "Edit Profile".

ps : sorry for my bad english.

EDIT :

This is the value in ProfAdminEdit.aspx (Central Administration --> Manage User Profiles). I display "C2" but I want the other value.

enter image description here

This is the value in EditProfile.aspx (in search navigation, I search e.g Lee and when I click on his name, I arrive on his personal site and there, I can "edit" his profil, I want the value that is here and not the value "C2")

enter image description here

bumped to the homepage by Community 2 days ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

In order to use a value from the User Profile in Search Results you have to create and map a Managed Property for the User Profile Property. Once you do that you can create a display template that will display the value in your search results.

I have written a complete walk through with examples of this process here: http://www.ableblue.com/blog/archive/2013/06/05/introduction-to-sharepoint-2013-display-templates/

EDIT It appears that your Managed Metadata Service and browser language settings are not configured correctly.

  • Thank you for your answer. I haven't problem to display my managed property (here "location"). The problem is that it displays the value that is in "Central Administration --> Manage User Profiles" and I want to display the value that is in "Edit Profile" when you click on the name of someone (when you use the search navigation for people e.g) and you go in his "Edit Profile", on the personal site of someone. I have different values. Do you understand? – Jayce Jul 9 '14 at 7:31
  • I don't understand. They should be the same value. Can you edit your question and add a couple screen shots? – Matthew McDermott Jul 9 '14 at 15:36
  • I edited my question. – Jayce Jul 9 '14 at 15:48
  • If you look at the Term Set and the Term "C2" in English, is the French translation the value you are seeing in your second image? Can you chance the UI language to English to test? – Matthew McDermott Jul 10 '14 at 13:20
  • Ok, when I change UI langage to English, I see "C2" instead of "Batiment...". But, now I change the langage settings of my siteCollection (Site Settings --> Language settings --> I checked French). The search center is in French but when I search people, I have always "C2". How to achieve this? – Jayce Jul 10 '14 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.