I have a clean installation of Sharepoint 2010 running in a Win 7 machine and I can't create Web Applications because the New button in the ribbon is disabled.

The user account I'm logged in is a local server admin and a farm admin. The site is in the Trusted Sites zone.

I googled it and the main suggestion seems to be running IE in Admin mode. I did this, didn't work. I also ran the Configuration Wizard, also no result.

Anybody has any idea why I have the button disabled?

Thank you in advance

  • Thanks a lot. I am struggling with this from many days. your article help me to come out from this problem. :)
    – user8904
    Commented Jun 17, 2012 at 3:31

16 Answers 16


Run your browser in elevated mode and the problem is resolved.

  • Funny but worked
    – Iman
    Commented Jun 24, 2015 at 10:07

Run the link of Central Administration as administrator.

This helps getting you correct permissions in Central Administration


Have seen this problem before.

There is a "Administrator" account on Win7 which is disabled by default. Log into Central Admin using that account. Start -> Run -> compmgmt.msc select "Local Users and Groups" and enable "Adminstrator" account and set a password.

Now login to Central Admin using this account.

  1. Open in as administrator in IE is working for me, or
  2. While configuring wizards you need to give your credentials, or
  3. Add your name in the Windows administrator group, then add your name in form administrator group 'CA-Security-Manage the from Administrator group'

Open the SharePoint Central Administration web page from another PC.


You could try to create a new web app via powershell. It will fail, but you might get an error message that points you to the problem.


I experienced the same issue (using Server 2008 R2). For some reason User Account Control (UAC) prevents a new web application from being created.

Go into "Control Panel" and switch "View By" to "Small Icons". Click on "User Accounts" and then click on "Change User Account Control Settings". Drag the slider down to "Never Notify".

Reboot the system. Nothing will change until the machine is restarted.

Open up IE as administrator and navigate to your central admin page. Now navigate to "Manage Web Applications" and the "New" option will appear.


Believe it or not, I could actually solve this issue by adding the central admin to the list of safe local intranet sites in IE (please note that it didn't work for trusted sites, just intranet sites).

I followed the steps in this tutorial (after trying many, many things) and it solved my issue: http://epmgelist.wordpress.com/2013/06/14/central-administration-greyed-out-ribbons-and-missing-functions/


Try AlexPoint his suggestion and monitor the ULS and the eventvwr logs.

Don't know if the account you use is the installation admin service account, if it isn't try logging on with that account and see if the option is there.

Keep us posted.


I have seen that behavior before (the new web app button was grayed out). When I have seen that, I go to the Security section of Central Admin to confirm the account was in Farm Admins and then go back to the Manage Web Applications area and the New button has been (mysteriously) activated and is usable.

It is possible you just restarted the machine? I haven't tested this theory, but I seem to see that after restarting a Virtual Machine, and I wonder if SharePoint was still starting things up or if some required process was not ready to allow the creation of a new web app, and, in the time it took me to go look at the Farm Admins page and return, it became ready.


All good suggestions - it can actually be a combination of a few..

1) Account you need to use is the Farm Account (must be a member of the SharePoint Farm Administrators Group added through Central Administration)

2) Farm account MUST be a member of the Local Users and Groups Administrators group

3) Must right click on the Central Administration icon and select "Run as administrator"

RECOMMENDATION TO ALL: Don't follow Microsoft's instructions to use an installation account - that is simply stupid. When you use a specific account for installation, services, etc. are assigned to it. If you want to then create a farm account, you'll waste much valuable time resetting service ID's, assigning to proper security groups, etc. Install using the Farm account (once assigned to the Local Users & Groups Administrators group). The same goes for using a SQL Server account - if you use an installation account (ala 2008) or accept the default accounts (ala 2012), same issue. Install using the account that will be running the services!


I tried all of the above suggestions & still got the issue. I then disabled IE Enhanced Security & that fixed it.


I experienced the same issue. I tried these suggestions;

  • I ran the browser in elevated mode but it didn't work.
  • I checked the windows permissions, but everything is normal.

then I tried to run SharePoin Product Configuration Wizard, it worked for me.


You have to run a browser on a different machine than where the central administration (and SharePoint itself) is installed. Otherwise, the webinterface won't work correctly. This also applies to the newest SharePoint Server 2019. Just figure out what the tcp port of the page is and connect via browser, but remotely.

Edit: You might have to run a private browser tab in order to be able to input the admin credentials


I think you install a new update for your Sharepoint. you should run again SharePoint Product Configuration Wizard to fix your issue.


I tried the same and ended up discovering that what "disabled" that ¤%(#& button was the fact that an old session of Edge browser was running minimized and apparently made it impossible for Edge/SharepointCA to handle it's own life.

Kill the old browser session and start CentralAdministration in admin mode again, and it worked..
(No, not the browser in admin mode, oh no that's not enough :p )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.