0

Something weird happens. When I try to connect to central administration from sharepoint application server it asks me about credentials. I try to log in with farm administrator permissions, but it doesn't let me log in.

When I try to login to the central administration from a local computer or the front end web service server using the same account, I am able to login. The problem continues with my web front end server also when I try to login in one of the sites it tells me to input credentials (again sp farm admin) and it doesn't work. When I try to login to the site from a local computer or the application server using the same account, I am able to login.

I know I can access the setting using other computers, but I wonder why this happens.

5
  • I am using SP2013 and Windows server 2012 r2 – el94 Jul 2 '14 at 11:21
  • 1
  • It's a security feature. – Christoffer Jul 2 '14 at 11:26
  • As already pointed out - DisableLoopbackCheck will solve this. – Mx. Jul 2 '14 at 13:21
  • And in addition, DO NOT disable it in your production environment. – Christoffer Jul 2 '14 at 13:32
5

This is a security feature from Microsoft, which are explained in detail here:

DisableLoopbackCheck & SharePoint: What every admin and developer should know.

It can sure be annoying but Microsoft did put it there for a reason. However, if you are on a development or staging environment you could disable it. But never ever do it in a production farm as it's there to keep your farm a little bit more safe.

Here's a easy guide about how you disable it.

DisableLoopbackCheck. Lets do it the right way

1
  • 1
    Or, if you need to crawl from the server itself, add the URL to the exclude link as explained in harbar link above – Robert Lindgren Jul 3 '14 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.