0

I have SharePoint 2013 installed on windows server 2008 R2. My current build version is :-

Major  Minor  Build  Revision
-----  -----  -----  --------
15     0      4481   1005

And to upgrade my SharePoint server 2013 , I run the SharePoint 2013 products configuration wizard, but the process fail and I got the following error:-

Task applicationcontent has failed with an unknown exception 
07/02/2014 12:04:31  17  ERR                Exception: System.IO.FileNotFoundException: Could not find file 'C:\inetpub\wwwroot\wss\VirtualDirectories\*****.local80\web.config'.
File name: 'C:\inetpub\wwwroot\wss\VirtualDirectories\****.local80\web.config'
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)

and when I open the 'C:\inetpub\wwwroot\wss\VirtualDirectories\*****.local80\ I can not find a web.config file? So can anyone advice what is causing this problem, and how to solve it ?

Thanks

3

How many Servers in the Farm? Web site mentioned in the error ( ****.local80) still exist and working?

If you have more than one server in farm, simply copy the web.config file from other server for same Virtual directory and re ran the Config wizard.

Or

Simply delete the Web Application( i am sure your web app not working as missing web.config) or re provision it. After that re ran the config wizard.

3

You will not find the file web.config in this folder

C:\inetpub\wwwroot\wss\VirtualDirectories\…local80\web.config'

The reason is your web.config file is deleted in your port 80. You have to have web.config file in this folder otherwise you will face this problem. I have the problem in port 40786. The solution is delete the website from your iis server and reconfigure your sharepoint server using sharepoint product wizard. Following are the steps:-

1)Open iis server in your computer where sharepoint server is installed.

2)In your left side, you will find the sharepoint sites .

3) Delete the sharepoint site with port number 80

4) Open the sharepoint product configuration wizard and reconfigure your sharepoint server by selecting the option * using the current sharepoint farm. You can try the option *creating a new farm but i did not use it.

Enjoy yourself!

  • my issues was similar to this, and deleting the sharepoint site on IIS worked. – AceMark Mar 18 '15 at 6:33
0
  • go to Start-->type IIS in search--> Open IIS
  • Expand the server instance
  • under sites
  • Delete the previous versions of SharePoint central administration
  • now go to cmd and reset IIS using IISRESET
  • Now go to SharePoint Products configuration
  • Select YES (Configure as new server)
  • give the server name
  • give the database name and database has some prerequisites (if creating manually check the collation,recovery model, Authentications on database for the ID you are configuring)
  • choose the NTLM and paraphrase to be given
  • click on finish after completing the process.

It will redirect you to the new share point central admin console.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.