6

I am using a Team Site template with Publishing feature Enabled. When user is trying to access the homepage, it is working as expected.

But when they trying to access any List / Libraries they simply prompt for loging or access denied. I don't know why?

I make sure, all pages are approve & published, also add anonymous access on all system libraries.

anything i am missing? I am SharePoint 2010.

  • Have you tried this? blog.cloudshare.com/2012/07/16/… – Christoffer Jun 30 '14 at 16:16
  • Look at the comments as well. The mod is stating that if you wanna restrict access to list and site content, then activate the publishing feature. Might help you out to deactivate it? – Christoffer Jun 30 '14 at 16:18
  • i already performed those steps but still no luck. – Waqas Sarwar MVP Jun 30 '14 at 16:19
  • blogs.msdn.com/b/varun_malhotra/archive/2012/01/13/… Check this out then, i still believe it got something to do with the publishing feature. – Christoffer Jun 30 '14 at 16:22
  • i think you are correct, i overlooked that part, i thought its team site so i dont need to worry even publishing feature....I was wrong...Thanks alot....solve the issue....Could you please add this as answer so that i can mark and give you points. – Waqas Sarwar MVP Jun 30 '14 at 16:39
7

When giving anonymous access to a publishing portal or a site with the publishing feature activate, there is an additional feature getting activated called ViewFormPagesLockdown. This feature prevents anonymous users from gaining access to certain areas of a site. That includes list forms.

From the blog:

This feature still exists in SharePoint 2010 and is still automatically turned on for Publishing Portal sites. This feature is referred to as lockdown mode and can be turned on or off by enabling/disabling the ViewFormPagesLockdown feature.

Lockdown Mode in SharePoint 2010

An additional good blogpost about why you should handle this feature with care.

Login prompt accessing list on SharePoint site with anonymous access enabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.